Bug 974923 - Cart-Data in JBossEWS and ZEND manifest file is referring to non-existing environment varaibles
Cart-Data in JBossEWS and ZEND manifest file is referring to non-existing ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 03:00 EDT by Lei Zhang
Modified: 2015-05-14 19:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:56:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lei Zhang 2013-06-17 03:00:23 EDT
Description of problem:
key of Cart-Data  jbossews/metadata/manifest.yml" is refering OPENSHIFT_JBOSSEAP_LOG_DIR", but the environment variable of jbossews app is actually  the "OPENSHIFT_JBOSSEWS_LOG_DIR" vairable

Version-Release number of selected component (if applicable):
devenv_3368
rhc-1.10.1 build from devenv_3368

How reproducible:
always

Steps to Reproduce:
1. rhc app create -a jbossw -t jbossews-2.0 
2. ssh login application and cat ./jbossews/metadata/manifest.yml|grep "OPENSHIFT_JBOSSEAP_LOG_DIR"
3. check environment variables: env |grep "OPENSHIFT_JBOSSEWS_LOG_DIR"

Actual results:
"OPENSHIFT_JBOSSEAP_LOG_DIR" is referenced  in Cart-Data  of jbossews/metadata/manifest.yml 

Expected results:
Jbossews manifest file should reference OPENSHIFT_JBOSSEWS_LOG_DIR

Additional info:
Comment 1 Lei Zhang 2013-06-17 04:00:24 EDT
Same issue exists in zend app, Cart-Data in zend manifest file is refering "OPENSHIFT_LOG_DIR", but the environment variable of zend app is actually  the "OPENSHIFT_ZEND_LOG_DIR" vairable.
Comment 3 openshift-github-bot 2013-06-17 17:29:56 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/8e26f269eb0df6e7eaedf9b7d77168019f9eb0d7
Bug 974923: Fix inaccurate Cart-Data env var references
Comment 4 Lei Zhang 2013-06-18 03:09:52 EDT
Test on devenv-3375, the issue still exist on zend app.
 
rhc app create -a myzend -t zend-5.6 and rhc app ssh myzend

[myzend-rayzhang.dev.rhcloud.com 974481095179726038761472]\> grep Key zend/metadata/manifest.yml 
  - Key: OPENSHIFT_LOG_DIR
  - Key: OPENSHIFT_TMP_DIR
  - Key: OPENSHIFT_REPO_DIR
  - Key: OPENSHIFT_ZEND_PORT
  - Key: OPENSHIFT_ZEND_IP
  - Key: OPENSHIFT_APP_DNS
  - Key: OPENSHIFT_APP_NAME
  - Key: OPENSHIFT_DATA_DIR
  - Key: OPENSHIFT_APP_UUID
  - Key: OPENSHIFT_GEAR_UUID

[myzend-rayzhang.dev.rhcloud.com 974481095179726038761472]\> env |grep LOG_DIR
OPENSHIFT_ZEND_LOG_DIR=/var/lib/openshift/974481095179726038761472/zend//logs/

See the key of Cart-Data  zend/metadata/manifest.yml is refering "OPENSHIFT_LOG_DIR", but the environment variable of zend app is actually  the "OPENSHIFT_ZEND_LOG_DIR" vairable
Comment 5 Dan Mace 2013-06-18 09:23:01 EDT
Looks like the li pull request got missed by the build bot and wasn't merged; I'll get it merged today and Zend should be fixed.

Thanks!
Comment 6 openshift-github-bot 2013-06-18 10:39:56 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/be27f79817ec7148b4991c178a54779c2a4fa9d9
Bug 974923: Fix inaccurate Cart-Data env var references
Comment 7 Lei Zhang 2013-06-19 02:33:50 EDT
Test on INT(devenv_3382), the issue has been fixed successfully.

[zendapp-ray.int.rhcloud.com 51c14e5e6cec0e9956000040]\> grep Key ./zend/metadata/manifest.yml
  - Key: OPENSHIFT_ZEND_LOG_DIR
  - Key: OPENSHIFT_TMP_DIR
  - Key: OPENSHIFT_REPO_DIR
  - Key: OPENSHIFT_ZEND_PORT
  - Key: OPENSHIFT_ZEND_IP
  - Key: OPENSHIFT_APP_DNS
  - Key: OPENSHIFT_APP_NAME
  - Key: OPENSHIFT_DATA_DIR
  - Key: OPENSHIFT_APP_UUID
  - Key: OPENSHIFT_GEAR_UUID

[zendapp-ray.int.rhcloud.com 51c14e5e6cec0e9956000040]\> echo $OPENSHIFT_ZEND_LOG_DIR
/var/lib/openshift/51c14e5e6cec0e9956000040/zend//logs/

Note You need to log in before you can comment on or make changes to this bug.