Bug 974927 - Removing app with oo-admin-clt-app when gear's dir does not exist will not delete symbolic link of this app.
Removing app with oo-admin-clt-app when gear's dir does not exist will not d...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 03:20 EDT by Liang Xia
Modified: 2015-05-14 19:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 11:01:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2013-06-17 03:20:20 EDT
Description of problem:
Removing  app with oo-admin-clt-app when gear's dir does not exist will not delete symbolic link of this app.

Version-Release number of selected component (if applicable):
devenv_3368
rhc-1.10.1

How reproducible:
always

Steps to Reproduce:
1.create an app and remove gear dir from node.
   (rhc app create ruby19 ruby1.9;)
   (rm -rf uuid_of_your_app)
2.on node, destroy this app.
   (oo-admin-ctl-app -b -a ruby19 -l lxia@redhat.com -c destroy)
3.check the dir /var/lib/openshift

Actual results:
The broken symbolic link to the app is not deleted.

Expected results:
All dir/file related to this app should be deleted.

Additional info:
Remove gear when gear's dir exist will delete symbolic link of this app successfully.
Comment 1 Jhon Honce 2013-09-24 11:01:11 EDT
After reviewing the solution to the problem, it was determined that the performance impact of the fix is too great. 

The symlink's are intended to only be created on development environments where the solution would impact both development and production environments negatively.

Note You need to log in before you can comment on or make changes to this bug.