Bug 97496 - (SOUND EMU10K1)emu10k1 loops first fraction of a second of sound
(SOUND EMU10K1)emu10k1 loops first fraction of a second of sound
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-16 14:30 EDT by David Juran
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.3-1.96
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-22 12:27:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (442 bytes, text/plain)
2003-06-16 14:31 EDT, David Juran
no flags Details

  None (edit)
Description David Juran 2003-06-16 14:30:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The symptoms of the problem are very similar to the ones of bug 73334, but
apperently they are unrelated, so I'm opening up mu own bug...
I've created this little test prgram I'm attaching here. When I run this, it
seems to writes some 4kB. to /dev/dsp and then hangs while the first second or
so of the sound keeps looping.
It seems however that there is some timing issue involved as well. If I
decrease the buffer size, sometimes the entire files can play (though the sound
is terribly broken up)

An excerpt from lspci -vvv
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
	Subsystem: Creative Labs SBLive! Player 5.1
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 7
	Region 0: I/O ports at b400 [size=32]
	Capabilities: [dc] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)

	Subsystem: Creative Labs Gameport Joystick
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32
	Region 0: I/O ports at b000 [size=8]
	Capabilities: [dc] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Further investigations have shown that the driver goes to sleep in
linux/drivers/sound/emu10k1/audio.c line 241 but is never awakened. 

Version-Release number of selected component (if applicable):
kernel-smp-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1.compile and run the attached test program
2.listen to the noise

    

Additional info:
Comment 1 David Juran 2003-06-16 14:31:27 EDT
Created attachment 92437 [details]
test case
Comment 2 David Juran 2003-11-13 16:00:44 EST
And the proble is still there in kernel-2.4.22-1.2115.nptl
Comment 3 David Juran 2004-02-22 12:27:36 EST
Since this has always worked using ALSA drivers and since they are now
incorporated into the 2.6 kernel, I'll just close this bug as RAWHIDE
(is this still the correct status athough it's not called rawhide
anymore?)

Note You need to log in before you can comment on or make changes to this bug.