Bug 974973 - success=yes AVC when running fail2ban service
success=yes AVC when running fail2ban service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 05:50 EDT by Michal Trunecka
Modified: 2014-09-30 19:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-210.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:31:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Trunecka 2013-06-17 05:50:55 EDT
Description of problem:
Following AVCs are reported during fail2ban service start, restart and stop:

----
time->Thu Jun 13 16:21:40 2013
type=SYSCALL msg=audit(1371154900.905:2637): arch=c000003e syscall=59 success=yes exit=0 a0=2798ca0 a1=279a1e0 a2=2799fd0 a3=28 items=0 ppid=5326 pid=5328 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=unconfined_u:system_r:system_mail_t:s0 key=(null)
type=AVC msg=audit(1371154900.905:2637): avc:  denied  { read } for  pid=5328 comm="sendmail" path="inotify" dev=inotifyfs ino=1 scontext=unconfined_u:system_r:system_mail_t:s0 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir
----
time->Thu Jun 13 16:21:45 2013
type=SYSCALL msg=audit(1371154905.488:2644): arch=c000003e syscall=59 success=yes exit=0 a0=ab7ca0 a1=ab91e0 a2=ab8fd0 a3=28 items=0 ppid=5456 pid=5459 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=unconfined_u:system_r:system_mail_t:s0 key=(null)
type=AVC msg=audit(1371154905.488:2644): avc:  denied  { read } for  pid=5459 comm="sendmail" path="inotify" dev=inotifyfs ino=1 scontext=unconfined_u:system_r:system_mail_t:s0 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-195.el6_4.11.noarch
fail2ban-0.8.8-3.el6.noarch
Comment 1 Daniel Walsh 2013-06-18 11:57:12 EDT
This is fail2ban leaking an open file descriptor to the mail program.

Should be assigned to fail2ban
Comment 2 Miroslav Grepl 2013-06-19 04:16:24 EDT
Yes, but AFAIK it is EPEL. We will need to fix it also in the policy.
Comment 5 errata-xmlrpc 2013-11-21 05:31:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1598.html

Note You need to log in before you can comment on or make changes to this bug.