This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 9750 - RH PPP Dialer (rp3) crashes with segmentation fault.
RH PPP Dialer (rp3) crashes with segmentation fault.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 08:11 EST by Jack Botner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-07 10:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack Botner 2000-02-24 08:11:18 EST
RH PPP Dialer (rp3) crashes with segmentation fault.

I applied the rp3 fix rp3-1.0.1-1.i386.rpm, but the problem persisted.

Call trace:

(gdb) r
Starting program: /usr/bin/rp3

Program received signal SIGSEGV, Segmentation fault.
strncmp (s1=0x805510c "ppp", s2=0x0, n=3) at
../sysdeps/generic/strncmp.c:65
65      ../sysdeps/generic/strncmp.c: No such file or directory.

(gdb) bt
#0  strncmp (s1=0x805510c "ppp", s2=0x0, n=3)
    at ../sysdeps/generic/strncmp.c:65
#1  0x80513ef in interface_status_update (i=0x8093100) at interface.c:417
#2  0x80511b0 in interface_new (interfaceName=0x8092ead "") at
interface.c:324
#3  0x8050dd6 in interface_list_generate () at interface.c:181
#4  0x804ead1 in properties_interface_choose () at properties.c:71
#5  0x804ea90 in properties_interface_get (chosenInterface=0x0) at
properties.c:50
#6  0x804d5a6 in application_main (argc=1, argv=0xbffffd04) at rp3.c:88
#7  0x804d8b2 in main (argc=1, argv=0xbffffd04) at rp3.c:169
(gdb)
Comment 1 Nalin Dahyabhai 2000-02-28 17:08:59 EST
I believe this bug is fixed in the latest version of rp3 from CVS, which we've
included in the 6.2 Beta.  Please grab a copy of the updated package from
http://people.redhat.com/nalin/test/ and let me know if it solves this problem.
Comment 2 Jack Botner 2000-03-06 17:37:59 EST
The problem was resolved after installing rp3-1.0.7-3.i386.rpm
Thanks.
Comment 3 Nalin Dahyabhai 2000-03-07 10:00:59 EST
Excellent.

Note You need to log in before you can comment on or make changes to this bug.