Bug 975061 - Servers deleted after content republish and promotion
Servers deleted after content republish and promotion
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
x86_64 Linux
high Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Og Maciel
: Triaged
: 956690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 10:28 EDT by robert.redhat
Modified: 2014-09-18 13:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:17:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack traces (24.00 KB, text/plain)
2013-06-17 10:28 EDT, robert.redhat
no flags Details

  None (edit)
Description robert.redhat 2013-06-17 10:28:28 EDT
Created attachment 762041 [details]
stack traces

Description of problem: After republishing a content view and promoting it to an environment, I get the following error:

Resources::Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer f61c6726-00f0-46fd-8c73-00090893786a has been deleted","deletedId":"f61c6726-00f0-46fd-8c73-00090893786a"} (GET /candlepin/consumers/f61c6726-00f0-46fd-8c73-00090893786a/compliance) (RestClient::Gone)
{"displayMessage":"Consumer f61c6726-00f0-46fd-8c73-00090893786a has been deleted","deletedId":"f61c6726-00f0-46fd-8c73-00090893786a"}


Version-Release number of selected component (if applicable):
Katello Version: 1.3.30-1.el6

How reproducible:
Somewhat

Steps to Reproduce:
Possible prior steps:
1. Demote content view from already assigned to systems

1. Publish content view that has already been published under a different name due to known bug where republishing a large view will cause a "Pulp id has already been taken" error.
2. Promote new content view name to existing environment
3. Click "systems"

Actual results:
Above mentioned error

Expected results:
Content is available to systems and systems are viewable

Additional info:
Comment 2 Justin Sherrill 2013-06-18 14:03:54 EDT
https://github.com/Katello/katello/pull/2516
Comment 3 Mike McCune 2013-06-19 10:56:45 EDT
*** Bug 956690 has been marked as a duplicate of this bug. ***
Comment 5 Brad Buckingham 2013-06-21 08:59:26 EDT
Mass move to ON_QA
Comment 6 Og Maciel 2013-06-22 18:28:04 EDT
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-compute-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10014-1.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-17.el6sat.noarch
* katello-all-1.4.2-17.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-17.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-17.el6sat.noarch
* katello-glue-candlepin-1.4.2-17.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-17.el6sat.noarch
* katello-glue-pulp-1.4.2-17.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-1.el6sat.noarch
* pulp-selinux-2.1.2-1.el6sat.noarch
* pulp-server-2.1.2-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:17:13 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.