Bug 975095 - HttpSession Object not cleaned up properly
HttpSession Object not cleaned up properly
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai (Show other bugs)
2.3.0
Unspecified Unspecified
urgent Severity urgent
: CR1
: 2.3.0
Assigned To: Pavel SLegr
Matous Jobanek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 11:49 EDT by Pavel SLegr
Modified: 2013-11-06 15:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 06:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ERRAI-574 Blocker Closed Session expires although the bus is active which causes reconnection attempts and possible message loss 2013-11-06 15:56:43 EST

  None (edit)
Description Pavel SLegr 2013-06-17 11:49:54 EDT
csadilek:"The problem is that our session object turned out to be not serializable in 2.3.0 or earlier. So, that was a super critical fix in 2.3.1 by itself (e.g to make Errai work in a cluster with session replication). Unfortunately, the fix introduced a problem when cleaning up sessions which also needs to be addressed (2.3.2)."
Comment 1 Pavel SLegr 2013-06-17 12:09:53 EDT
There is known fix in upstream https://github.com/errai/errai/commit/4c9bbbbe84b2a49be6cdc4746b332c47a2e61efe by Jonathan.

The question is, include into CR1 only this fix or to wait for 2.3.2.Final Errai release, which should be available this week.

Given the fact we are closed to WFK-2.3 CR1, I would not go the way of including 2.3.2.Final but only backporting this fix, as other commits alogn the way 2.3.1 --> 2.3.2 might bring into a new regresions, which is not desirable.
Comment 4 Matous Jobanek 2013-06-26 08:39:34 EDT
Verified in WFK 2.3.0.CR1
Comment 5 JBoss JIRA Server 2013-11-06 15:56:43 EST
Christian Sadilek <csadilek@redhat.com> updated the status of jira ERRAI-574 to Closed

Note You need to log in before you can comment on or make changes to this bug.