Bug 975285 - Delete option 'nomodeset' in kernel parameters for the selected boot option that wasn't marked Basic Video.
Summary: Delete option 'nomodeset' in kernel parameters for the selected boot option t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 868767
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-18 02:39 UTC by haiyang,dong
Modified: 2014-01-21 19:41 UTC (History)
15 users (show)

Fixed In Version: ovirt-node-3.0.1-7.el6
Doc Type: Bug Fix
Doc Text:
Non-"basic video" boot entries were being booted in basic video mode. This was caused by the nomodeset kernel argument being added to non "basic video" entries. This was fixed by ensuring the nomodeset kernel argument is only used in the "basic video" boot entries. This means that Basic Video boot entries boot with the nomodeset kernel argument, all others don't.
Clone Of: 868767
Environment:
Last Closed: 2014-01-21 19:41:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 0 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-22 00:14:30 UTC

Description haiyang,dong 2013-06-18 02:39:03 UTC
+++ This bug was initially created as a clone of Bug #868767 +++

Description of problem:
Insert the installation media(CD-ROM/USB), and start the system, When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...
press the Tab key to check kernel parameters for the selected boot option:
Install or Upgrade with serial console
Reinstall
Reinstall with serial console
Uninstall
These boot option wasn't marked Basic Video, so that the option "nomodeset" in kernel parameters for the selected boot option
should be deleted.

Also i notice that there are duplicate "nomodeset" in these options:
Install(Basic Video)
Reinstall(Basic Video)
May need to delete one.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
100% 
 
Steps to Reproduce:
1.Insert the installation media(CD-ROM/USB), and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...
3.press the Tab key to check kernel parameters for these boot option.

Actual result:
These boot options weren't marked Basic Video contain the option "nomodeset" in kernel parameters 

Expect result:
These boot options weren't marked Basic Video, so that the option "nomodeset" in kernel parameters for the selected boot option
should be deleted.

Additional info:

--

Comment 6 haiyang,dong 2013-10-20 05:36:14 UTC
Still could reproduce this bug on rhev-hypervisor6-6.5-20131017.0.iso, also due to it's a regression bug.so need "priority" as high.

Comment 10 haiyang,dong 2013-11-01 02:37:54 UTC
Test version:
rhevh-6.5-20131031.1.0.iso
ovirt-node-3.0.1-7.el6

Tested as follows:
1.Insert the installation media(CD-ROM/USB), and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
        Automatic boot in 30 seconds...
3.press the Tab key to check kernel parameters for these boot option.

Notice that:
press the Tab key to check kernel parameters for the selected boot option(wasn't marked Basic Video):
Install or Upgrade
Install or Upgrade with serial console
Reinstall
Reinstall with serial console
Uninstall
Boot from local drive

the option "nomodeset" in kernel parameters for the selected boot option
has been deleted.

Also i notice that in these options:
Install(Basic Video)
Reinstall(Basic Video)
Only save one "nomodeset" in kernel parameters 

so this bug has been fixed, change the status into "VERIFIED"

Comment 12 Cheryn Tan 2013-11-08 00:31:17 UTC
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 15 errata-xmlrpc 2014-01-21 19:41:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html


Note You need to log in before you can comment on or make changes to this bug.