Bug 975302 - Duplicate actions: "Download All files (offline po zip)" in JSF File list view with File project type
Duplicate actions: "Download All files (offline po zip)" in JSF File list vie...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 00:08 EDT by Ding-Yi Chen
Modified: 2013-11-26 22:22 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0-alpha-2-SNAPSHOT (20130708-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:22:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-06-18 00:08:19 EDT
Description of problem:
With "File" project type, duplicated actions: "Download All files (offline po zip)" appeared in JSF Document list view. One enabled, another one disabled.

Only File project-type is affected, other project-type are fine.


Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130618-1217)

How reproducible:
Always

Steps to Reproduce:
1. In the project/version view for a File project.
2. Click document icon at any language
   JSF Document list view should be loaded.

Actual results:
Two duplicated actions: "Download All files (offline po zip)" appeared.
one enabled, one disabled.

Expected results:
Only one "Download All files (offline po zip)" should appear.

Additional info:
Comment 1 David Mason 2013-06-18 03:20:53 EDT
This seems to have been caused by an attempt to remove a condition from css:

https://github.com/zanata/zanata-server/commit/44514bdc
Comment 2 Alex Eng 2013-06-18 18:07:35 EDT
Fixed in 3.0 alpha 2-SNAPSHOT

See https://github.com/zanata/zanata-server/commit/1fa43434792ea056f8a19c57f1e0d22ebce7def7
Comment 3 Ding-Yi Chen 2013-07-07 21:08:48 EDT
VERIFIED with Zanata version 3.0.0-alpha-2-SNAPSHOT (20130708-0019).
Comment 4 Sean Flanigan 2013-11-26 22:22:38 EST
Closing bugs which were VERIFIED with snapshots <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.