Bug 975423 - auto-deleted queues for outgoing links from an exchange are not in fact autodeleted
auto-deleted queues for outgoing links from an exchange are not in fact autod...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Ernie
:
Depends On:
Blocks: 974061
  Show dependency treegraph
 
Reported: 2013-06-18 08:52 EDT by Gordon Sim
Modified: 2015-01-21 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-5.el6, qpid-cpp-0.22-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (902 bytes, application/x-shellscript)
2013-07-17 13:25 EDT, Ernie
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4819 None None None Never

  None (edit)
Description Gordon Sim 2013-06-18 08:52:07 EDT
Description of problem:

A previous fix (which may not have been made available in RHEL packages) caused autodeleted queues not to be deleted when required.

Version-Release number of selected component (if applicable):

not sure

How reproducible:

100%

Steps to Reproduce:
1. qpid-receive --connection-options {protocol:amqp1.0} --address amq.topic
(run several times to make observing the issue easier)

Actual results:

subscription queue left on broker 

Expected results:

subscription queue cleaned up when receiver closes
Additional info:
Comment 1 Justin Ross 2013-06-21 07:22:55 EDT
http://svn.apache.org/r1480238
Comment 2 Ernie 2013-07-17 13:25:50 EDT
Created attachment 774874 [details]
Reproducer

Loops 50 times and creates temp auto-del queues on outgoing links. Tests if number of auto-del queues before and after looping is the same.
Comment 3 Ernie 2013-07-17 13:31:04 EDT
Verified. rhel 5.9 / 6.4 (32 and 64)
      RHEL 5.9
        cyrus-sasl-2.1.22-7.el5_8.1
        cyrus-sasl-devel-2.1.22-7.el5_8.1
        cyrus-sasl-lib-2.1.22-7.el5_8.1
        cyrus-sasl-plain-2.1.22-7.el5_8.1
        python-qpid-0.22-4.el5
        python-qpid-qmf-0.22-5.el5
        python-saslwrapper-0.22-2.el5
        qpid-cpp-client-0.22-6.el5
        qpid-cpp-client-devel-0.22-6.el5
        qpid-cpp-server-0.22-6.el5
        qpid-java-client-0.22-2.el5
        qpid-java-common-0.22-2.el5
        qpid-java-example-0.22-2.el5
        qpid-proton-c-0.4-2.2.el5
        qpid-qmf-0.22-5.el5
        qpid-tools-0.22-2.el5
        saslwrapper-0.22-2.el5

      RHEL 6.4
        cyrus-sasl-2.1.23-13.el6_3.1
        cyrus-sasl-devel-2.1.23-13.el6_3.1
        cyrus-sasl-gssapi-2.1.23-13.el6_3.1
        cyrus-sasl-lib-2.1.23-13.el6_3.1
        cyrus-sasl-md5-2.1.23-13.el6_3.1
        cyrus-sasl-plain-2.1.23-13.el6_3.1
        python-qpid-0.22-4.el6.noarch
        python-qpid-qmf-0.22-5.el6
        python-saslwrapper-0.22-3.el6
        qpid-cpp-client-0.22-6.el6
        qpid-cpp-client-devel-0.22-6.el6
        qpid-cpp-server-0.22-6.el6
        qpid-proton-c-0.4-2.2.el6
        qpid-proton-c-devel-0.4-2.2.el6
        qpid-qmf-0.22-5.el6
        qpid-tools-0.22-3.el6.noarch
        saslwrapper-0.22-3.el6

NOT reproduced since this bug was reported against an unknown devel revision.

Note You need to log in before you can comment on or make changes to this bug.