Bug 975443 - gnome ignores systemwide language and keyboard settings
gnome ignores systemwide language and keyboard settings
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-desktop (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 09:30 EDT by Thomas Schweikle
Modified: 2017-12-06 05:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:23:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2013-06-18 09:30:02 EDT
Description of problem:
gnome does not respect system language settings. They are ignored completely. Every user has to set keyboard and language by himself. 


Version-Release number of selected component (if applicable):
gnome-applets-2.28.0-7.el6.x86_64
gnome-bluetooth-libs-2.28.6-8.el6.x86_64
gnome-desktop-2.28.2-11.0.1.el6.x86_64
gnome-disk-utility-libs-2.30.1-2.el6.x86_64
gnome-doc-utils-stylesheets-0.18.1-1.el6.noarch
gnome-icon-theme-2.28.0-2.el6.noarch
gnome-keyring-2.28.2-8.el6_3.x86_64
gnome-keyring-pam-2.28.2-8.el6_3.x86_64
gnome-mag-0.15.9-2.el6.x86_64
gnome-media-2.29.91-6.el6.x86_64
gnome-media-libs-2.29.91-6.el6.x86_64
gnome-menus-2.28.0-4.el6.x86_64
gnome-packagekit-2.28.3-7.el6.x86_64
gnome-panel-2.30.2-14.el6.x86_64
gnome-panel-libs-2.30.2-14.el6.x86_64
gnome-power-manager-2.28.3-7.el6_4.x86_64
gnome-python2-2.28.0-3.el6.x86_64
gnome-python2-applet-2.28.0-4.el6.x86_64
gnome-python2-bonobo-2.28.0-3.el6.x86_64
gnome-python2-canvas-2.28.0-3.el6.x86_64
gnome-python2-desktop-2.28.0-4.el6.x86_64
gnome-python2-extras-2.25.3-20.el6.x86_64
gnome-python2-gconf-2.28.0-3.el6.x86_64
gnome-python2-gnome-2.28.0-3.el6.x86_64
gnome-python2-gnomekeyring-2.28.0-4.el6.x86_64
gnome-python2-gnomevfs-2.28.0-3.el6.x86_64
gnome-python2-libegg-2.25.3-20.el6.x86_64
gnome-python2-libwnck-2.28.0-4.el6.x86_64
gnome-screensaver-2.28.3-24.el6.x86_64
gnome-session-2.28.0-18.el6.x86_64
gnome-session-xsession-2.28.0-18.el6.x86_64
gnome-settings-daemon-2.28.2-30.el6.x86_64
gnome-speech-0.4.25-3.1.el6.x86_64
gnome-terminal-2.31.3-8.el6.x86_64
gnome-themes-2.28.1-6.el6.noarch
gnome-user-docs-2.28.0-4.el6.noarch
gnome-vfs2-2.24.2-6.el6.x86_64
gnome-vfs2-smb-2.24.2-6.el6.x86_64
libgail-gnome-1.20.1-4.1.el6.x86_64
libgnome-2.28.0-11.el6.x86_64
libgnomecanvas-2.26.0-4.el6.x86_64
libgnomekbd-2.28.2-2.el6.x86_64
libgnomeui-2.24.1-4.el6.x86_64
NetworkManager-gnome-0.8.1-43.el6.x86_64
polkit-gnome-0.96-3.el6.x86_64
rhn-setup-gnome-1.0.0.1-4.0.1.el6.noarch
system-gnome-theme-60.0.2-1.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Enterprise Linux 6.4.
2. Set system language and keyboard to, say german
3. Install gnome desktop
4. Login to gnome desktop, open gnome-terminal type german umlaute, watch them displayed as '{[]}' and others.


Actual results:
After installing gnome then opening any application keyboard layout is US-english, while in any terminal "echo $LANG" tells about "LANG=de_DE.UTF-8" (in gnome terminal typing german umlaut "a" leads to "["). Keyboard-settings are as expected in "/etc/sysconfig/keyboard":
KEYTABLE="de"
MODEL="pc105"
LAYOUT="de"
KEYBOARDTYPE="pc"
VARIANT="nodeadkeys"


Expected results:
gnome respecting the system language and system keyboard settings.


Additional info:
The system settings are respected by X11. Only gnome doesn't use them. The only way out is to set the language and keyboard by a user by user base. This can be annoying, if you have more than only a few users ...!
Comment 2 RHEL Product and Program Management 2013-10-13 19:28:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jan Kurik 2017-12-06 05:23:26 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.