Bug 9755 - "fdisk -l" doesn't work as it did in previous version
Summary: "fdisk -l" doesn't work as it did in previous version
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
: 8226 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-24 16:29 UTC by Steve Coile
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 22:34:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Coile 2000-02-24 16:29:39 UTC
/sbin/fdisk included with util-linux-2.9w-28, when invoked with the "-l"
switch, does not work as it does under RHL 6.0.  The newer version appears
to require a device specification, whereas older versions would list
partition information for all connected IDE and SCSI drives if no device
specification is given.

It appears that this change in behavior was introduced in RHL 6.1.  The man
page suggests that the device specification isn't necessary with the "-l"
flag.

Comment 1 Dale Lovelace 2000-03-05 15:44:59 UTC
*** Bug 8226 has been marked as a duplicate of this bug. ***

Comment 2 Erik Troan 2001-02-06 22:34:47 UTC
This was fixed with the introduction of /proc/partitions, but the parsing didn't
always worked properly so I went ahead and fixed that for 2.10p-6


Note You need to log in before you can comment on or make changes to this bug.