Bug 975534 - yum wants to install an i686 packages during an obsoleting process for mesa-libEGL-devel
yum wants to install an i686 packages during an obsoleting process for mesa-l...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 13:33 EDT by Heldwin
Modified: 2015-02-17 10:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:37:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heldwin 2013-06-18 13:33:58 EDT
Description of problem:
during an update, I am getting a few i686 packages that want to install on my x86_64 systems.

---> Package mesa-libEGL.x86_64 0:9.2-0.9.20130610.fc19 will be updated
---> Package mesa-libEGL.x86_64 0:9.2-0.11.20130610.fc19 will be an update
---> Package mesa-libEGL-devel.x86_64 0:9.2-0.9.20130610.fc19 will be updated
---> Package mesa-libEGL-devel.i686 0:9.2-0.11.20130610.fc19 will be obsoleting
--> Processing Dependency: libEGL.so.1 for package: mesa-libEGL-devel-9.2-0.11.20130610.fc19.i686
---> Package mesa-libEGL-devel.x86_64 0:9.2-0.11.20130610.fc19 will be obsoleting
---> Package mesa-libGL.x86_64 0:9.2-0.9.20130610.fc19 will be updated
---> Package mesa-libGL.x86_64 0:9.2-0.11.20130610.fc19 will be an update


Version-Release number of selected component (if applicable):
yum-utils-1.1.31-14.fc19.noarch
yum-3.4.3-95.fc19.noarch
yum-metadata-parser-1.1.4-8.fc19.x86_64


How reproducible:
should be always if mesa-libEGL-devel is installed


Actual results:
---> Package mesa-libEGL.i686 0:9.2-0.11.20130610.fc19 will be installed
--> Processing Dependency: libxcb.so.1 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libxcb-xfixes.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libxcb-shape.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libxcb-render.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libxcb-dri2.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libwayland-server.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libwayland-client.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libudev.so.1(LIBUDEV_183) for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libudev.so.1 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libselinux.so.1 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libpthread.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libglapi.so.0 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libgbm.so.1 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libdrm.so.2 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libdl.so.2 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libX11.so.6 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686
--> Processing Dependency: libX11-xcb.so.1 for package: mesa-libEGL-9.2-0.11.20130610.fc19.i686


Expected results:
These packages shouldn't be installed, as they exists in x86_64. and the i686 is not needed.

Additional info:
It doesn't do it with DNF.
Comment 1 Heldwin 2013-06-18 13:43:52 EDT
--> Processing Dependency: libEGL.so.1 for package: mesa-libEGL-devel-9.2-0.11.20130610.fc19.i686

I forgot to mention that libEGL.so.1 seems to only exist in the i686 package of mesa-libEGL 

LANG=C yum whatprovides libEGL.so.1

Loaded plugins: langpacks
mesa-libEGL-9.2-0.9.20130610.fc19.i686 : Mesa libEGL runtime libraries
Repo        : fedora
Matched from:
Provides    : libEGL.so.1

mesa-libEGL-9.2-0.11.20130610.fc19.i686 : Mesa libEGL runtime libraries
Repo        : updates-testing
Matched from:
Provides    : libEGL.so.1
Comment 2 Heldwin 2013-06-20 17:43:09 EDT
After removing khrplatform-devel

and then reinstalling:
pango-devel 
libcanberra-devel 
gtk2-engines-devel 
gtk3-devel 
gtk2-devel 
cairo-gobject-devel

I was able to update my system correctly, without these i686 packages

It updated : mesa-libEGL, and installed as dependency:
caro-devel
mesa-libEGL-devel

(all in x86_64)
Comment 3 Andrew Clayton 2013-09-01 07:43:13 EDT
I am seeing a similar issue on Fedora 18. --exclude *.i686 worked around it for me.

From the below, I assume this is due to the khrplatform-devel.noarch package being replaced by mesa-libEGL-devel which is an arch specific package, so it
decides to pull in both x86_64 and i686?

Resolving Dependencies
--> Running transaction check
---> Package khrplatform-devel.noarch 0:9.2-0.7.20130528.fc18 will be obsoleted
---> Package libvisio.x86_64 0:0.0.28-1.fc18 will be updated
---> Package libvisio.x86_64 0:0.0.30-1.fc18 will be an update
---> Package mesa-dri-drivers.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-dri-drivers.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-filesystem.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-filesystem.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libEGL.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libEGL.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libEGL-devel.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libEGL-devel.i686 0:9.2-0.12.20130610.fc18 will be obsoleting
--> Processing Dependency: libEGL.so.1 for package: mesa-libEGL-devel-9.2-0.12.20130610.fc18.i686
---> Package mesa-libEGL-devel.x86_64 0:9.2-0.12.20130610.fc18 will be obsoleting
---> Package mesa-libGL.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libGL.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libGL-devel.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libGL-devel.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libgbm.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libgbm.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libglapi.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libglapi.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package mesa-libxatracker.x86_64 0:9.2-0.7.20130528.fc18 will be updated
---> Package mesa-libxatracker.x86_64 0:9.2-0.12.20130610.fc18 will be an update
---> Package scribus.x86_64 0:1.4.2-2.fc18 will be updated
---> Package scribus.x86_64 0:1.4.3-1.fc18 will be an update
--> Running transaction check
---> Package mesa-libEGL.i686 0:9.2-0.12.20130610.fc18 will be installed
--> Processing Dependency: libxcb.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libxcb-xfixes.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libxcb-shape.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libxcb-render.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libxcb-dri2.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libwayland-server.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libwayland-client.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libudev.so.1(LIBUDEV_183) for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libudev.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libselinux.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: librt.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libpthread.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libglapi.so.0 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libgbm.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libdrm.so.2 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libdl.so.2 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libX11.so.6 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Processing Dependency: libX11-xcb.so.1 for package: mesa-libEGL-9.2-0.12.20130610.fc18.i686
--> Running transaction check
---> Package glibc.i686 0:2.16-33.fc18 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.16-33.fc18.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.16-33.fc18.i686
---> Package libX11.i686 0:1.5.99.901-3.20130524gita3bdd2b09.fc18 will be installed
---> Package libdrm.i686 0:2.4.45-1.fc18 will be installed
--> Processing Dependency: libpciaccess.so.0 for package: libdrm-2.4.45-1.fc18.i686
---> Package libselinux.i686 0:2.1.12-7.3.fc18 will be installed
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.1.12-7.3.fc18.i686
---> Package libwayland-client.i686 0:1.0.5-1.fc18 will be installed
--> Processing Dependency: libffi.so.5 for package: libwayland-client-1.0.5-1.fc18.i686
---> Package libwayland-server.i686 0:1.0.5-1.fc18 will be installed
---> Package libxcb.i686 0:1.9-3.fc18 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.9-3.fc18.i686
---> Package mesa-libgbm.i686 0:9.2-0.12.20130610.fc18 will be installed
---> Package mesa-libglapi.i686 0:9.2-0.12.20130610.fc18 will be installed
---> Package systemd-libs.i686 0:201-2.fc18.7 will be installed
--> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libpam.so.0 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: liblzma.so.5 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libgcc_s.so.1 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libdbus-1.so.3 for package: systemd-libs-201-2.fc18.7.i686
--> Processing Dependency: libcap.so.2 for package: systemd-libs-201-2.fc18.7.i686
--> Running transaction check
---> Package dbus-libs.i686 1:1.6.12-1.fc18 will be installed
---> Package libXau.i686 0:1.0.6-4.fc18 will be installed
---> Package libcap.i686 0:2.22-5.fc18 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-5.fc18.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.22-5.fc18.i686
---> Package libffi.i686 0:3.0.10-3.fc18 will be installed
---> Package libgcc.i686 0:4.7.2-8.fc18 will be installed
---> Package libgcrypt.i686 0:1.5.3-1.fc18 will be installed
---> Package libgpg-error.i686 0:1.10-3.fc18 will be installed
---> Package libpciaccess.i686 0:0.13.1-2.fc18 will be installed
---> Package nss-softokn-freebl.i686 0:3.15.1-1.fc18 will be installed
---> Package pam.i686 0:1.1.6-4.fc18 will be installed
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.6-4.fc18.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.6-4.fc18.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.6-4.fc18.i686
---> Package pcre.i686 0:8.31-5.fc18 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.31-5.fc18.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.31-5.fc18.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.31-5.fc18.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.31-5.fc18.i686
---> Package xz-libs.i686 0:5.1.2-2alpha.fc18 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.3.1-2.fc18 will be installed
---> Package cracklib.i686 0:2.8.22-2.fc18 will be installed
--> Processing Dependency: libz.so.1 for package: cracklib-2.8.22-2.fc18.i686
---> Package libattr.i686 0:2.4.46-7.fc18 will be installed
---> Package libdb.i686 0:5.3.21-3.fc18 will be installed
---> Package libstdc++.i686 0:4.7.2-8.fc18 will be installed
--> Running transaction check
---> Package zlib.i686 0:1.2.7-9.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch   Version                                Repository
                                                                           Size
================================================================================
Installing:
 mesa-libEGL-devel  i686   9.2-0.12.20130610.fc18                 updates  24 k
     replacing  khrplatform-devel.noarch 9.2-0.7.20130528.fc18
 mesa-libEGL-devel  x86_64 9.2-0.12.20130610.fc18                 updates  24 k
     replacing  khrplatform-devel.noarch 9.2-0.7.20130528.fc18
Updating:
 libvisio           x86_64 0.0.30-1.fc18                          updates 247 k
 mesa-dri-drivers   x86_64 9.2-0.12.20130610.fc18                 updates  11 M
 mesa-filesystem    x86_64 9.2-0.12.20130610.fc18                 updates  20 k
 mesa-libEGL        x86_64 9.2-0.12.20130610.fc18                 updates  71 k
 mesa-libGL         x86_64 9.2-0.12.20130610.fc18                 updates 129 k
 mesa-libGL-devel   x86_64 9.2-0.12.20130610.fc18                 updates 129 k
 mesa-libgbm        x86_64 9.2-0.12.20130610.fc18                 updates  28 k
 mesa-libglapi      x86_64 9.2-0.12.20130610.fc18                 updates  32 k
 mesa-libxatracker  x86_64 9.2-0.12.20130610.fc18                 updates 666 k
 scribus            x86_64 1.4.3-1.fc18                           updates  20 M
Installing for dependencies:
 audit-libs         i686   2.3.1-2.fc18                           updates  74 k
 cracklib           i686   2.8.22-2.fc18                          fedora   76 k
 dbus-libs          i686   1:1.6.12-1.fc18                        updates 152 k
 glibc              i686   2.16-33.fc18                           updates 4.2 M
 libX11             i686   1.5.99.901-3.20130524gita3bdd2b09.fc18 updates 601 k
 libXau             i686   1.0.6-4.fc18                           fedora   25 k
 libattr            i686   2.4.46-7.fc18                          fedora   17 k
 libcap             i686   2.22-5.fc18                            updates  47 k
 libdb              i686   5.3.21-3.fc18                          fedora  726 k
 libdrm             i686   2.4.45-1.fc18                          updates 120 k
 libffi             i686   3.0.10-3.fc18                          fedora   25 k
 libgcc             i686   4.7.2-8.fc18                           fedora   93 k
 libgcrypt          i686   1.5.3-1.fc18                           updates 250 k
 libgpg-error       i686   1.10-3.fc18                            fedora   77 k
 libpciaccess       i686   0.13.1-2.fc18                          fedora   26 k
 libselinux         i686   2.1.12-7.3.fc18                        updates 136 k
 libstdc++          i686   4.7.2-8.fc18                           fedora  292 k
 libwayland-client  i686   1.0.5-1.fc18                           updates  22 k
 libwayland-server  i686   1.0.5-1.fc18                           updates  31 k
 libxcb             i686   1.9-3.fc18                             updates 170 k
 mesa-libEGL        i686   9.2-0.12.20130610.fc18                 updates  71 k
 mesa-libgbm        i686   9.2-0.12.20130610.fc18                 updates  29 k
 mesa-libglapi      i686   9.2-0.12.20130610.fc18                 updates  48 k
 nss-softokn-freebl i686   3.15.1-1.fc18                          updates 146 k
 pam                i686   1.1.6-4.fc18                           updates 721 k
 pcre               i686   8.31-5.fc18                            updates 344 k
 systemd-libs       i686   201-2.fc18.7                           updates 144 k
 xz-libs            i686   5.1.2-2alpha.fc18                      fedora  108 k
 zlib               i686   1.2.7-9.fc18                           fedora   90 k

Transaction Summary
Comment 4 Fedora End Of Life 2015-01-09 13:28:11 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-17 10:37:27 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.