Bug 975539 - Jenkins: Builds won't start after Jenkins admin password is changed.
Jenkins: Builds won't start after Jenkins admin password is changed.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On: 975255
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 13:49 EDT by Luke Meyer
Modified: 2017-03-08 12 EST (History)
8 users (show)

See Also:
Fixed In Version: openshift-origin-cartridge-jenkins-1.9.8-1.el6op
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 975255
Environment:
Last Closed: 2013-06-28 11:45:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-06-18 13:49:57 EDT
+++ This bug was initially created as a clone of Bug #975255 +++

Description of problem:
See https://www.openshift.com/forums/openshift/jenkins-build-error-401-when-password-changed-using-jenkins-webapp  

When you change the admin password, builds no longer kick off as an error is thrown:  
java.io.IOException: Server returned HTTP response code: 401 for URL: http://127.5.130.1:8080/job/phptest-build/config.xml  
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1625)

When you change the admin password back to $JENKINS_PASSWORD, builds start to work again.

--- Additional comment from Meng Bo on 2013-06-18 02:18:57 EDT ---

Checked on devenv_3375, reproduced this issue.

For this problem, jenkins server will trigger the jenkins build with admin user now, which was and should be system_builder.

SSH login to the jenkins server will get the following ENV:
JENKINS_PASSWORD=r5jrAUV4_xU-
JENKINS_USERNAME=admin

After change the admin password, the ENV JENKINS_PASSWORD will not be changed accordingly.

When trigger jenkins build, will get the following info from jenkins log:

Jun 18, 2013 2:02:25 AM hudson.plugins.openshift.OpenShiftCloud reloadConfig
INFO: Retrieving config XML from http://127.0.251.1:8080/job/php1-build/config.xml
Jun 18, 2013 2:02:25 AM hudson.plugins.openshift.OpenShiftCloud createConnection
INFO: Using credentials admin:r5jrAUV4_xU-
Jun 18, 2013 2:02:26 AM hudson.plugins.openshift.OpenShiftCloud reloadConfig
WARNING: Reload GET:
Jun 18, 2013 2:02:26 AM hudson.plugins.openshift.OpenShiftCloud provision
WARNING: Caught java.io.IOException: Server returned HTTP response code: 401 for URL: http://127.0.251.1:8080/job/php1-build/config.xml. Will retry 1 more times before canceling build.


We should use the system_builder which password cannot be changed to trigger jenkins build.

--- Additional comment from Dan McPherson on 2013-06-18 13:08:47 EDT ---

https://github.com/openshift/origin-server/pull/2882

This will fix existing apps and get rid of the issue for new apps.
Comment 2 Luke Meyer 2013-06-19 10:33:59 EDT
Consensus seems to be to pull this in for 1.2. $large_customer would probably be very annoyed with this bug.
Comment 3 Gaoyun Pei 2013-06-24 00:33:14 EDT
Verified this issue on puddle:
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-06-21.2/


jenkins server was using system_builder for jenkins build

...
Jun 23, 2013 9:17:16 PM hudson.plugins.openshift.OpenShiftCloud reloadConfig
INFO: Retrieving config XML from http://127.0.250.1:8080/job/php-build/config.xml
Jun 23, 2013 9:17:16 PM hudson.plugins.openshift.OpenShiftCloud createConnection
INFO: Using credentials system_builder:t4xqXqJC8jg1
...
Comment 4 Luke Meyer 2013-06-28 11:45:59 EDT
Closing all bugs introduced, fixed, and verified during 1.2 release work (thus never shipped).

Note You need to log in before you can comment on or make changes to this bug.