Bug 975554 - trine2 for linux segfaulting under mesa-dri-drivers-9.2-0.11.20130610.fc19.i686
trine2 for linux segfaulting under mesa-dri-drivers-9.2-0.11.20130610.fc19.i686
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 14:48 EDT by Jeff Layton
Modified: 2014-06-18 03:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 10:18:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2013-06-18 14:48:38 EDT
I was playing Trine 2 for linux from Steam. It had been working fine on my f19 machine, but after today's yum update it started segfaulting. It's unfortunately a closed-source program, so I don't have much of a stack trace but I was able to get this much:

Core was generated by `./bin/trine2_linux_32bit -RenderingModule:DetectedFullscreenWidth=3360 -Renderi'.
Program terminated with signal 11, Segmentation fault.
#0  0xe4e5f89a in _mesa_BindFramebuffer () from /usr/lib/dri/r600_dri.so
Missing separate debuginfos, use: debuginfo-install glibc-2.17-4.fc19.i686 libdrm-2.4.45-1.fc19.i686 libtxc_dxtn-1.0.0-3.fc19.i686 libxcb-1.9-3.fc19.i686 llvm-libs-3.3-0.6.rc3.fc19.i686 mesa-dri-drivers-9.2-0.11.20130610.fc19.i686 mesa-libGL-9.2-0.11.20130610.fc19.i686 mesa-libglapi-9.2-0.11.20130610.fc19.i686
(gdb) bt
#0  0xe4e5f89a in _mesa_BindFramebuffer () from /usr/lib/dri/r600_dri.so
#1  0xf6b6abee in glBindFramebufferEXT () from /lib/libGL.so.1
#2  0x08be1f59 in ?? ()
#3  0x08be35db in ?? ()
#4  0x08c78e23 in ?? ()
#5  0x08ca71b7 in ?? ()
#6  0x08cc03e2 in ?? ()
#7  0x08c616c1 in ?? ()
#8  0x08c62e1f in ?? ()
#9  0x08c63762 in ?? ()
#10 0x08c66663 in ?? ()
#11 0x08bb23cc in ?? ()
#12 0x08ba808d in ?? ()
#13 0x0836529b in ?? ()
#14 0x08400026 in ?? ()
#15 0x0835efea in ?? ()
#16 0x083e31f6 in ?? ()
#17 0x083c21e4 in ?? ()
#18 0x08d211df in ?? ()
#19 0x08d2210c in ?? ()
#20 0x08d10072 in ?? ()
#21 0x08d207c6 in ?? ()
#22 0x0805c69e in ?? ()
#23 0x4a0f4963 in __libc_start_main () from /lib/libc.so.6
#24 0x0805f295 in ?? ()
(gdb) quit

...downgrading all of the mesa-related packages to 9.2-0.9.20130610.fc19 seems to have gotten it working again, so it seems to be a regression in there. Let me know if you need any other info.
Comment 1 Jeff Layton 2013-06-25 10:18:20 EDT
This seems to be fixed with the latest mesa (mesa-dri-drivers-9.2-0.12.20130610.fc19.i686)

Note You need to log in before you can comment on or make changes to this bug.