Bug 975586 - Can't add localised domain name alias -- Invalid Server Alias specified
Can't add localised domain name alias -- Invalid Server Alias specified
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 16:17 EDT by bugzilla+redhat.com
Modified: 2015-05-14 20:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_3388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:57:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bugzilla+redhat.com 2013-06-18 16:17:07 EDT
When trying to add a localised domain name alias through web interface, an error message saying "Invalid Server Alias '[..]' specified" appears.
Comment 1 bugzilla+redhat.com 2013-06-18 16:18:48 EDT
Aliases (different from current ones) added earlier to another application continue to work fine but no new similar aliases are considered as valid.
Comment 2 Abhishek Gupta 2013-06-18 19:41:58 EDT
What is the alias that you are trying to add?
Comment 3 bugzilla+redhat.com 2013-06-19 01:40:21 EDT
For www-kylad.rhcloud.com tried with:

xn--klad-0ra.ee
www.xn--klad-0ra.ee
külad.ee
www.külad.ee

For kaart-lahim.rhcloud.com tried with:

kaart.xn--lhim-loa.ee
Comment 4 Abhishek Gupta 2013-06-19 14:16:15 EDT
The current validations for alias was blocking multiple dashes from being back-to-back in the name. That has been fixed with --> https://github.com/openshift/origin-server/pull/2902

The other issue is that we do not support UTF (non ASCII) characters in the alias since we have not implemented the RFC below for the translation of UTF characters in the domain name.

http://tools.ietf.org/html/rfc3490
Comment 5 openshift-github-bot 2013-06-19 16:58:26 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/41473dce9a91a1250b0a8a75025aa0b352e97fed
Fix for bug 975586
 - Alowing multiple dashes in alias
Comment 6 zhaozhanqi 2013-06-20 01:08:58 EDT
Tested this issue on devenv_3389, it has been fixed

[zqzhao@dhcp-13-222 ~]$ rhc alias add zqphps www.xn--klad-0ra.ee
Alias 'www.xn--klad-0ra.ee' has been added.

[zqzhao@dhcp-13-222 ~]$ rhc alias add zqphps kaart.xn--lhim-loa.ee
Alias 'kaart.xn--lhim-loa.ee' has been added.

[zqzhao@dhcp-13-222 ~]$ rhc alias add zqphps xn--klad-0ra.ee
Alias 'xn--klad-0ra.ee


[zqzhao@dhcp-13-222 ~]$ rhc alias list zqphps
Alias                 Has Certificate? Certificate Added
--------------------- ---------------- -----------------
xn--klad-0ra.ee       no               -
www.xn--klad-0ra.ee   no               -
kaart.xn--lhim-loa.ee no               

[zqzhao@dhcp-13-222 ~]$ rhc alias remove zqphps www.xn--klad-0ra.ee
Alias 'www.xn--klad-0ra.ee' has been removed.


[zqzhao@dhcp-13-222 ~]$ rhc alias list zqphps
Alias                 Has Certificate? Certificate Added
--------------------- ---------------- -----------------
xn--klad-0ra.ee       no               -
kaart.xn--lhim-loa.ee no
Comment 7 bugzilla+redhat.com 2013-06-27 04:52:22 EDT
Sorry to bother but when could be the expected deployment of the fix?
Comment 8 Xiaoli Tian 2013-06-27 06:54:34 EDT
(In reply to bugzilla+redhat.com from comment #7)
> Sorry to bother but when could be the expected deployment of the fix?

It should be deployed on July 1st if no unexpected issues happen
Comment 9 bugzilla+redhat.com 2013-06-28 14:53:01 EDT
Thanks for information, will look forward to it.

Note You need to log in before you can comment on or make changes to this bug.