This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 975634 - [Docs] [Admin] virtio-scsi installer for 2008/2012/2003
[Docs] [Admin] virtio-scsi installer for 2008/2012/2003
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Tim Hildred
ecs-bugs
integration
: FutureFeature
Depends On: 967607
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 21:31 EDT by Tim Hildred
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 967607
Environment:
Last Closed: 2014-04-06 23:09:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Tim Hildred 2013-07-15 00:30:25 EDT
Hello Lev,

I'm trying to make sure the documentation captures this feature. 

Could you please help me understand:

1) How does the user experience this feature? Is this a new driver installed of guest tools iso after install? Floppy during install? Other way?

2) How to add an entry for virtio-scsi in "Table 15.3. Red Hat Enterprise Virtualization Guest Drivers". Does this driver provide similar functionality for virtio-block?

3) In what circumstances would a user choose this device driver over other ones?

Thank you for your help Lev.
Comment 2 Lev Veyde 2013-07-15 04:45:18 EDT
(In reply to Tim Hildred from comment #1)
> Hello Lev,
> 
> I'm trying to make sure the documentation captures this feature. 
> 
> Could you please help me understand:
> 
> 1) How does the user experience this feature? Is this a new driver installed
> of guest tools iso after install? Floppy during install? Other way?
> 
> 2) How to add an entry for virtio-scsi in "Table 15.3. Red Hat Enterprise
> Virtualization Guest Drivers". Does this driver provide similar
> functionality for virtio-block?
> 
> 3) In what circumstances would a user choose this device driver over other
> ones?
> 
> Thank you for your help Lev.

Hi Tim,

1) Since it's a storage driver it included on both the floppy image (otherwise the user won't have an option to originally install the OS on the Virtio-SCSI device) and in the Windows Guest Tools (allowing him to add additional Virtio-SCSI devices).

2) I'm not sure to what document/table you are referring to. Can you please provide me with a link?

3) A lot of useful information about the new Virtio-SCSI driver is available at http://www.ovirt.org/Features/Virtio-SCSI .

Generally the main advantage is for the customers that need to add hundreds of block devices (disks) to the OS, as with Virtio-Block they are limited to about 30, but there are more advantages that may cause some clients to prefer using Virtio-SCSI over Virtio-Block (i.e. if they plan to export the VMs later on to another (other vendor) Virtualization env.) as the device naming is more standard) etc.

Thanks in advance,
Lev Veyde.
Comment 5 Tim Hildred 2013-07-25 03:38:52 EDT
Related to:
https://bugzilla.redhat.com/show_bug.cgi?id=921114
Comment 7 Tim Hildred 2013-10-04 05:10:48 EDT
The way I've resolved this bug is:

Updated: Red Hat Enterprise Virtualization Guest Drivers and Guest Agents
"Paravirtualized iSCSI HDD driver offers similar functionality to the virtio-block device, with some additional enhancements. In particular, this driver supports adding hundreds of devices, and names devices using the standard SCSI device naming scheme."

And added: Installing Windows on VirtIO-optimized Hardware

Note You need to log in before you can comment on or make changes to this bug.