Bug 975792 - Creating Jenkins server in INT sometimes fails with Node execution errors and failure of executing all parallel operations
Creating Jenkins server in INT sometimes fails with Node execution errors and...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 07:16 EDT by Zhe Wang
Modified: 2015-05-14 19:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-06-19 07:16:34 EDT
Description of problem:
It sometimes fails to create a Jenkins server with node execution error. Moreover, the errors are frequently (not always though) returned when creating a Jenkins server along with JBoss applications or scaling applications.

Version-Release number of selected component (if applicable):
INT(devenv_3382)

How reproducible:
Sometimes

Steps to Reproduce:
1. Create a Jenkins server with RHC

Actual results:
The creating sometimes fails. For instance,

Running Command - rhc app create jenkins jenkins-1.4 -l jizhao+3@redhat.com -p redhat --insecure --timeout 360
Application Options
-------------------
Namespace: 9qpzo2832t
Cartridges: jenkins-1.4
Gear Size: default
Scaling: no

Creating application 'jenkins' ... Unable to complete the requested operation due to: Node execution failure (invalid exit code from node). If the problem persists please contact Red Hat support..
Reference ID: 3090733b96b0a8bfa6655acf3d75bad8

Expected results:
It should be successful to create a Jenkins server.

Additional info:
Comment 1 Zhe Wang 2013-06-28 02:05:21 EDT
The problem also exists in STG(devenv-stage_382). For example, 

Running Command - rhc app create jenkins jenkins-1.4 -l xtian+test4@redhat.com -p 123456  --timeout 360
Application Options
-------------------
  Namespace:  83ri2yjopt
  Cartridges: jenkins-1.4
  Gear Size:  default
  Scaling:    no

Creating application 'jenkins' ... Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..
Reference ID: 3bf0c07d6e8b9f1c39060ac47b07e660
Command Return: 1
Comment 2 Zhe Wang 2013-07-30 04:49:37 EDT
This problem was reproducible in the test against INT(devenv_3578):


Running Command - rhc app create jenkins jenkins-1.4 -l xtian+test3@redhat.com -p 123456 --no-git --insecure --timeout 360
Application Options
-------------------
  Namespace:  gef2hqry44
  Cartridges: jenkins-1.4
  Gear Size:  default
  Scaling:    no

Creating application 'jenkins' ... Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..
Reference ID: 5d3d5971fea77cfe57a8a2a5ff04cea7

Running Command - rhc app create jenkinsiikd7 jenkins-1.4 -l jizhao+3@redhat.com -p redhat --no-git --insecure --timeout 360
Application Options
-------------------
  Namespace:  19jup60yj2
  Cartridges: jenkins-1.4
  Gear Size:  default
  Scaling:    no

Creating application 'jenkinsiikd7' ... Server returned an unexpected error code: 504

[zhe@fedora run107]$ rhc app create jenkins jenkins-1.4 
Application Options
-------------------
  Namespace:  zwint
  Cartridges: jenkins-1.4
  Gear Size:  default
  Scaling:    no

Creating application 'jenkins' ... 
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: 2617c4606d0a6b60b84d8450d37abfe8
Comment 3 Zhe Wang 2013-07-30 23:02:50 EDT
The problem still exists in INT(devenv_3586)

Running Command - rhc app create jenkins jenkins-1.4 -l zhewang+2@redhat.com -p redhat  --insecure --timeout 360
Application Options
-------------------
  Namespace:  sesf1kh6dz
  Cartridges: jenkins-1.4
  Gear Size:  default
  Scaling:    no

Creating application 'jenkins' ... Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..
Reference ID: f5648d4544b86c5c9e8b1ddb33a0265b
Comment 4 Dan McPherson 2013-07-31 13:05:08 EDT
I looked in the INT logs and indeed you still failed to start jenkins in time.  I tried to recreate against INT 20+ times without any failures.

I am going to increase the timeout a little more.  But how often is this failing for you?
Comment 5 Dan McPherson 2013-07-31 13:05:28 EDT
https://github.com/openshift/origin-server/pull/3244
Comment 7 Zhe Wang 2013-08-01 06:02:24 EDT
Hi, Daniel,

Thanks for your fix, and I did not meet this problem in today's auto test against INT(devenv_3595), so I have moved this bug to VERIFIED.

FYI, this bug was reproducible in INT sometimes, not very often. I will keep an eye on this issue, if possible, I will try to give you some statistics.

Thanks,
Zhe Wang

Note You need to log in before you can comment on or make changes to this bug.