Bug 975849 - No mid-air collision reported when changing QA Contact
No mid-air collision reported when changing QA Contact
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 09:01 EDT by Hubert Kario
Modified: 2014-10-12 18:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 07:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Kario 2013-06-19 09:01:36 EDT
Description of problem:
When two people change the QA Assigned field at the same time, no mid-air collision is reported

Version-Release number of selected component (if applicable):
4.4

How reproducible:
unknown

Steps to Reproduce:
1. Edit bug's QA Assigned field using one account
2. Edit bug's QA Assigned using second account
3. Submit changes on first account
4. Submit changes from second account

Actual results:
The last change overwrites the previous one, no collision is reported..

Expected results:
Collision is reported, as in the case of adding of a new comment.

Additional info:
Comment 2 Simon Green 2013-07-01 21:49:32 EDT
I cannot reproduce this. As expected, I get a mid air collision warning when completing step 4.

  -- simon
Comment 3 Hubert Kario 2013-07-02 06:10:51 EDT
I've hit this problem only once, so it might have been a fluke...

Ideas in no particular order:
1. Maybe there's a timeout and changes using 2 or 3 minute old forms are overriding the change?
2. The specific change occurred by switching the bug from specific e-mail to default one for the package from one side and from specific e-mail to different e-mail on the other person's side. (mine -> Reset to default for component and other -> take)
Comment 4 Simon Green 2013-07-02 07:28:52 EDT
(In reply to Hubert Kario from comment #3)
> I've hit this problem only once, so it might have been a fluke...
> 
> Ideas in no particular order:
> 1. Maybe there's a timeout and changes using 2 or 3 minute old forms are
> overriding the change?

Timeout on tokens is 3 days. When you hit this limit, you will receive a warning saying you didn't submit the form correctly, and are you sure you want to make this change.

> 2. The specific change occurred by switching the bug from specific e-mail to
> default one for the package from one side and from specific e-mail to
> different e-mail on the other person's side. (mine -> Reset to default for
> component and other -> take)

That wouldn't make a difference. If the other person used the 'Change many bugs at once' page that would be a reason the mid air collision didn't happen. This is a known issue, and was in the Bugzilla 4.4 release notes.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.