Bug 975936 - NPE in MessageImpl hiding a KiePackage compilation error
NPE in MessageImpl hiding a KiePackage compilation error
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: DR6
: 6.0.0
Assigned To: Mario Fusco
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 11:52 EDT by Marek Winkler
Modified: 2014-08-06 16:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
timers-calendars.csv (843 bytes, text/plain)
2013-06-19 12:02 EDT, Marek Winkler
no flags Details

  None (edit)
Description Marek Winkler 2013-06-19 11:52:43 EDT
Description of problem:

When compiling a KiePackage containing CSV file (most likely with compilation errors) only, the following NPE is thrown:

java.lang.NullPointerException: null
	at org.drools.compiler.kie.builder.impl.MessageImpl.<init>(MessageImpl.java:49)
	at org.drools.compiler.kie.builder.impl.ResultsImpl.addMessage(ResultsImpl.java:39)
	at org.drools.compiler.kie.builder.impl.AbstractKieModule.buildKnowledgePackages(AbstractKieModule.java:190)
	at org.drools.compiler.kie.builder.impl.AbstractKieProject.verify(AbstractKieProject.java:39)
	at org.drools.compiler.kie.builder.impl.KieBuilderImpl.buildKieModule(KieBuilderImpl.java:269)
	at org.drools.compiler.kie.builder.impl.KieBuilderImpl.buildAll(KieBuilderImpl.java:169)

The problem is probably related to result.getResource() being null.

Version-Release number of selected component (if applicable):

Drools 6.0.0-SNAPSHOT
BRMS 6.0.0.DR5
Comment 1 Marek Winkler 2013-06-19 12:02:33 EDT
Created attachment 763033 [details]
timers-calendars.csv
Comment 2 Mario Fusco 2013-06-19 13:27:08 EDT
Fixed.
Comment 3 Marek Winkler 2013-08-08 11:21:34 EDT
Verified on 6.0.0.DR6.

Note You need to log in before you can comment on or make changes to this bug.