Bug 976041 - Repository version inconsist between mesa-libGL & mesa-libGL-devel
Repository version inconsist between mesa-libGL & mesa-libGL-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 15:31 EDT by timjhutchinson
Modified: 2013-06-20 03:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 03:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description timjhutchinson 2013-06-19 15:31:57 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.52 Safari/537.36
Build Identifier: 

Attempting to install mesalib and its development counterpart on an x86_64 machine. However the version numbers of the the two packages are different, giving installation errors.

[root@g h]# yum list mesa-libGL
Loaded plugins: langpacks, refresh-packagekit
Installed Packages
mesa-libGL.x86_64            9.2-0.11.20130610.fc19             @updates-testing
Available Packages
mesa-libGL.i686              9.2-0.9.20130610.fc19              fedora          
[root@g h]# yum list mesa-libGL-devel
Loaded plugins: langpacks, refresh-packagekit
Available Packages
mesa-libGL-devel.i686                 9.2-0.9.20130610.fc19               fedora
mesa-libGL-devel.x86_64               9.2-0.9.20130610.fc19               fedora

Reproducible: Always

Steps to Reproduce:
1. yum install mesa-libGL-devel
2.
3.
Actual Results:  
[root@g h]# yum install mesa-libGL-devel
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package mesa-libGL-devel.x86_64 0:9.2-0.9.20130610.fc19 will be installed
--> Processing Dependency: mesa-libGL = 9.2-0.9.20130610.fc19 for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xcb-glx) >= 1.8.1 for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xcb-dri2) >= 1.8 for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.24 for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xfixes) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xext) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(x11-xcb) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: pkgconfig(x11) for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Processing Dependency: gl-manpages for package: mesa-libGL-devel-9.2-0.9.20130610.fc19.x86_64
--> Running transaction check
---> Package gl-manpages.noarch 0:1.1-6.20130122.fc19 will be installed
---> Package libX11-devel.x86_64 0:1.5.99.902-1.fc19 will be installed
--> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.5.99.902-1.fc19.x86_64
--> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.5.99.902-1.fc19.x86_64
---> Package libXdamage-devel.x86_64 0:1.1.4-3.fc19 will be installed
---> Package libXext-devel.x86_64 0:1.3.2-1.fc19 will be installed
---> Package libXfixes-devel.x86_64 0:5.0.1-1.fc19 will be installed
---> Package libXxf86vm-devel.x86_64 0:1.1.3-1.fc19 will be installed
---> Package libdrm-devel.x86_64 0:2.4.45-1.fc19 will be installed
---> Package libxcb-devel.x86_64 0:1.9-3.fc19 will be installed
--> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.9-3.fc19.x86_64
---> Package mesa-libGL.i686 0:9.2-0.9.20130610.fc19 will be installed
--> Processing Dependency: libxcb.so.1 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libxcb-glx.so.0 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libxcb-dri2.so.0 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libselinux.so.1 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libpthread.so.0 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libm.so.6 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libglapi.so.0 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libdrm.so.2 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libdl.so.2 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libXxf86vm.so.1 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libXfixes.so.3 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libXext.so.6 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libXdamage.so.1 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libX11.so.6 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Processing Dependency: libX11-xcb.so.1 for package: mesa-libGL-9.2-0.9.20130610.fc19.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-4.fc19 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-4.fc19.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-4.fc19.i686
---> Package libX11.i686 0:1.5.99.902-1.fc19 will be installed
---> Package libXau-devel.x86_64 0:1.0.8-1.fc19 will be installed
---> Package libXdamage.i686 0:1.1.4-3.fc19 will be installed
---> Package libXext.i686 0:1.3.2-1.fc19 will be installed
---> Package libXfixes.i686 0:5.0.1-1.fc19 will be installed
---> Package libXxf86vm.i686 0:1.1.3-1.fc19 will be installed
---> Package libdrm.i686 0:2.4.45-1.fc19 will be installed
--> Processing Dependency: libpciaccess.so.0 for package: libdrm-2.4.45-1.fc19.i686
---> Package libselinux.i686 0:2.1.13-15.fc19 will be installed
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.1.13-15.fc19.i686
---> Package libxcb.i686 0:1.9-3.fc19 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.9-3.fc19.i686
---> Package mesa-libglapi.i686 0:9.2-0.9.20130610.fc19 will be installed
---> Package xorg-x11-proto-devel.noarch 0:7.7-4.fc19 will be installed
--> Running transaction check
---> Package libXau.i686 0:1.0.8-1.fc19 will be installed
---> Package libpciaccess.i686 0:0.13.1-3.fc19 will be installed
---> Package nss-softokn-freebl.i686 0:3.15-3.fc19 will be installed
---> Package pcre.i686 0:8.32-7.fc19 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-7.fc19.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-7.fc19.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-7.fc19.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-7.fc19.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.32-7.fc19.i686
--> Processing Dependency: libgcc_s.so.1 for package: pcre-8.32-7.fc19.i686
--> Running transaction check
---> Package libgcc.i686 0:4.8.1-1.fc19 will be installed
---> Package libstdc++.i686 0:4.8.1-1.fc19 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for mesa-libGL which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of mesa-libGL of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude mesa-libGL.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of mesa-libGL installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of mesa-libGL installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: mesa-libGL-9.2-0.9.20130610.fc19.i686 != mesa-libGL-9.2-0.11.20130610.fc19.x86_64
Error: Protected multilib versions: mesa-libglapi-9.2-0.9.20130610.fc19.i686 != mesa-libglapi-9.2-0.11.20130610.fc19.x86_64
[root@g h]# 


Expected Results:  
Package should install
Comment 1 Jan Zeleny 2013-06-20 03:08:48 EDT
Well, you can see the explanation right in the list of available packages. The installed version of mesa-libGL comes from updates-testing repo where there are usually newer versions of packages. From the list of available versions of mesa-libGL-devel you can see that the package is not available in that version.

Possible causes:
a) the testing update has been pulled back from the testing repo
b) the repo with testing updates is now disabled on your system

In any case, not a bug in yum.

Note You need to log in before you can comment on or make changes to this bug.