Bug 976043 - [abrt] firewall-config-0.2.12-5.fc18: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Python.dbus.exceptions.DBusException: INVALID_PROTOCOL: ssl
[abrt] firewall-config-0.2.12-5.fc18: connection.py:651:call_blocking:DBusExc...
Status: CLOSED DUPLICATE of bug 951850
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:935abe1392de6f1f2f5b7df1ff9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 15:41 EDT by Warren
Modified: 2013-06-20 07:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 07:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.10 KB, text/plain)
2013-06-19 15:41 EDT, Warren
no flags Details
File: core_backtrace (770 bytes, text/plain)
2013-06-19 15:41 EDT, Warren
no flags Details
File: dso_list (97 bytes, text/plain)
2013-06-19 15:41 EDT, Warren
no flags Details
File: environ (1.39 KB, text/plain)
2013-06-19 15:41 EDT, Warren
no flags Details

  None (edit)
Description Warren 2013-06-19 15:41:06 EDT
Description of problem:
I originally started out trying to configure the firewall to allow my email reply to go out. I was using the Evolution client and referring to the ports listed in the Gmail help.  Since I was in a hurry, I didn't document everything that was done. I do know that I tried to enable ssl for smtp, as specified in the Gmail online blog.  I hope this helps, sketchy though it is.  Thanks...

Version-Release number of selected component:
firewall-config-0.2.12-5.fc18

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.9.5-201.fc18.i686
runlevel:       N 5
uid:            1000

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Python.dbus.exceptions.DBusException: INVALID_PROTOCOL: ssl

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 1655, in onServiceDialogAddPort
    self.add_edit_port_proto(True)
  File "/usr/bin/firewall-config", line 1312, in add_edit_port_proto
    service.update(settings)
  File "<string>", line 2, in update
  File "/usr/lib/python2.7/site-packages/slip/dbus/polkit.py", line 103, in _enable_proxy
    return func(*p, **k)
  File "/usr/lib/python2.7/site-packages/firewall/client.py", line 283, in update
    self.fw_service.update(tuple(settings.settings))
  File "/usr/lib/python2.7/site-packages/slip/dbus/proxies.py", line 50, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.dbus.exceptions.DBusException: INVALID_PROTOCOL: ssl

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x94fd3ec>
args: (('', 'Mail (SMTP)', "This option allows incoming SMTP mail delivery. If you need to allow remote hosts to connect directly to your machine to deliver mail, enable this option. You do not need to enable this if you collect your mail from your ISP's server by POP3 or IMAP, or if you use a tool such as fetchmail. Note that an improperly configured SMTP server can allow remote machines to use your server to send spam.", [('465', 'ssl')], [], {}),)
object_path: '/org/fedoraproject/FirewallD1/config/service/3'
signature: u'(sssa(ss)asa{ss})'
bus_name: dbus.UTF8String(':1.8')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: 2147483.647
kwargs: {}
dbus_interface: 'org.fedoraproject.FirewallD1.config.service'
message: <dbus.lowlevel.MethodCallMessage path: /org/fedoraproject/FirewallD1/config/service/3, iface: org.fedoraproject.FirewallD1.config.service, member: update dest: :1.8>
method: 'update'
Comment 1 Warren 2013-06-19 15:41:10 EDT
Created attachment 763127 [details]
File: backtrace
Comment 2 Warren 2013-06-19 15:41:13 EDT
Created attachment 763128 [details]
File: core_backtrace
Comment 3 Warren 2013-06-19 15:41:15 EDT
Created attachment 763129 [details]
File: dso_list
Comment 4 Warren 2013-06-19 15:41:32 EDT
Created attachment 763130 [details]
File: environ
Comment 5 Jiri Popelka 2013-06-20 07:27:07 EDT
It was caused by trying to open port 465/ssl, where ssl is not an ip protocol, you most likely want to open 465/tcp.

But firewall-config should definitely not crash, we need to backport
better error handling.

*** This bug has been marked as a duplicate of bug 951850 ***

Note You need to log in before you can comment on or make changes to this bug.