Bug 976105 - all locales are broken
all locales are broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 19:08 EDT by Olivier Crête
Modified: 2016-11-24 10:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 15:46:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2013-06-19 19:08:31 EDT
Probably a locale.alias problem, might be the same as #971416 and #928729

[ocrete@TesterTop4 ~]$ LANG=en_CA locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_CA
LC_CTYPE="en_CA"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="en_CA"
LC_MONETARY=\'\'
LC_MESSAGES="en_CA"
LC_PAPER=\'\'
LC_NAME="en_CA"
LC_ADDRESS="en_CA"
LC_TELEPHONE="en_CA"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="en_CA"
LC_ALL=
Comment 1 Olivier Crête 2013-06-19 19:11:15 EDT
Actually, not locale.alias problem.. different problem !
Comment 2 Olivier Crête 2013-06-19 20:54:56 EDT
Actually, it'S not en_CA specific at all

[ocrete@TesterTop4 ~]$ LANG=fr locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr
LC_CTYPE="fr"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="fr"
LC_MONETARY=\'\'
LC_MESSAGES="fr"
LC_PAPER=\'\'
LC_NAME="fr"
LC_ADDRESS="fr"
LC_TELEPHONE="fr"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="fr"
LC_ALL=
[ocrete@TesterTop4 ~]$ LANG=fr_CA locale
locale: Ne peut initialiser LC_ALL � la locale par d�faut: Aucun fichier ou dossier de ce type
LANG=fr_CA
LC_CTYPE="fr_CA"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="fr_CA"
LC_MONETARY=\'\'
LC_MESSAGES="fr_CA"
LC_PAPER=\'\'
LC_NAME="fr_CA"
LC_ADDRESS="fr_CA"
LC_TELEPHONE="fr_CA"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="fr_CA"
LC_ALL=
[ocrete@TesterTop4 ~]$ LANG=en_US locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="en_US"
LC_MONETARY=\'\'
LC_MESSAGES="en_US"
LC_PAPER=\'\'
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="en_US"
LC_ALL=
[ocrete@TesterTop4 ~]$ LANG=C locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=C
LC_CTYPE="C"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="C"
LC_MONETARY=\'\'
LC_MESSAGES="C"
LC_PAPER=\'\'
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="C"
LC_ALL=
[ocrete@TesterTop4 ~]$
Comment 3 Olivier Crête 2013-06-21 15:46:07 EDT
Hmm, it seems something in the early boot was setting a bunch of LC_* variables to '' and that was confusing glibc, but I couldn't figure out what it was, as after I rebooted the problem was gone. So I assume it's already fixed. Sorry for the noise

Note You need to log in before you can comment on or make changes to this bug.