This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 976109 - Updating the Depends On field with a long list produces an error.
Updating the Depends On field with a long list produces an error.
Status: CLOSED DUPLICATE of bug 970440
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 19:40 EDT by John Skeoch
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 20:11:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Skeoch 2013-06-19 19:40:07 EDT
Description of problem:
When adding a large list of bug numbers (400+) to the "Depends on" field Bugzilla first confirms the public visibility of the bug then produces the following error:

> URL: https://partner-bugzilla.redhat.com/process_bug.cgi
> Invalid parameter passed to Bugzilla::User->visible_bugs: It must be numeric.
>
> Traceback:
>
>  at Bugzilla/User.pm line 1027
>         Bugzilla::User::visible_bugs_or(...) called at Bugzilla/User.pm line 926
>         Bugzilla::User::visible_bugs(...) called at Bugzilla/User.pm line 919
>         Bugzilla::User::can_see_bug(...) called at Bugzilla/BugMail.pm line 606
>         Bugzilla::BugMail::_get_diff_alias(...) called at Bugzilla/BugMail.pm line 346
>         Bugzilla::BugMail::sendMail(...) called at Bugzilla/BugMail.pm line 274
>         Bugzilla::BugMail::Send(...) called at Bugzilla/Bug.pm line 1473
>         Bugzilla::Bug::_send_bugmail(...) called at Bugzilla/Bug.pm line 1409
>         Bugzilla::Bug::send_changes(...) called at /var/www/html/bugzilla/process_bug.cgi line 512

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Open an existing bug
2. Edit the Depends On field
3. Add long list of Bug numbers (400+)
4. Confirm the bug can be public (if that is the bug status)
5. Error produced

Actual results:
Depends on field is unchanged

Expected results:
Depends on field should include the long list.

Additional info:
Comment 2 Simon Green 2013-06-20 20:11:41 EDT
Looking at the traceback it seems this is the same as bug 970440.

*** This bug has been marked as a duplicate of bug 970440 ***

Note You need to log in before you can comment on or make changes to this bug.