Bug 976122 - print warning when accepting vm edits which will require stop/start of the VM to take effect
print warning when accepting vm edits which will require stop/start of the VM...
Status: CLOSED DUPLICATE of bug 971967
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
All Linux
medium Severity medium
: ---
: 3.4.0
Assigned To: Omer Frenkel
Pavel Stehlik
virt
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 21:09 EDT by Pratik Pravin Bandarkar
Modified: 2014-01-05 04:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 04:45:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2013-06-19 21:09:08 EDT
Description of problem:
 When we try to pin hosts cpu to vm on fly then , rhevm is accepting the value. But, changes are reflecting only if we shut down the vm and again start it(not reboot). So, if anyone try to pin hosts cpu to vm on fly then then RHEVM should throw an error/warning message.

Version-Release number of selected component (if applicable):
rhevm-3.2.0-11.30.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start the vm.
2. Edit the vm.
3. Go to host tab.
4. Try adding value for "CPU Pinning topology".
5. RHEVM will accept the value. But, changes will not reflect on the vm.

Actual results:
RHEVM accept the value even if vm is running.

Expected results:
RHEVM should not accept the value if vm is in running state. OR it should throw some message on RHEVM webUI.

Additional info:
Comment 1 Itamar Heim 2013-06-20 02:06:29 EDT
we have a reverse bug to allow editing values to only take action post the reboot, so i prefer we don't fix this one.
Comment 2 Pratik Pravin Bandarkar 2013-06-21 20:36:46 EDT
(In reply to Itamar Heim from comment #1)
> we have a reverse bug to allow editing values to only take action post the
> reboot, so i prefer we don't fix this one.

I got your point. But, it will be great if RHEVM throw an warning message if any user try to edit "CPU Pinning topology" parameter while vm is running. As RHEVM is accepting the value, users might have an impression that the changes will immediately get reflect. 

Also, I saw one case in which customer was thinking in the same way.

-Pratik.
Comment 3 Itamar Heim 2013-06-23 10:38:13 EDT
I'm pretty sure its a dup
Comment 4 Michal Skrivanek 2013-07-01 09:57:58 EDT
we should somehow visually differentiate between the fields which are applied immediately and which later.
Comment 5 Itamar Heim 2014-01-05 04:45:34 EST
i think i found the dup...

*** This bug has been marked as a duplicate of bug 971967 ***

Note You need to log in before you can comment on or make changes to this bug.