Bug 976125 - Problem with Wifi after sleep
Problem with Wifi after sleep
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 21:18 EDT by Joshua Kugler
Modified: 2013-08-06 11:56 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.10.4-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 04:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog of wireless trying to reconnect (30.78 KB, application/x-bzip)
2013-06-19 21:18 EDT, Joshua Kugler
no flags Details

  None (edit)
Description Joshua Kugler 2013-06-19 21:18:45 EDT
Created attachment 763188 [details]
syslog of wireless trying to reconnect

Description of problem:

Wireless connections work fine, until it wakes from sleep.  I 
see three "direct probes" (among other things), and then connection fails.


Version-Release number of selected component (if applicable):

kernel 3.9.4

How reproducible:

Every time.

Steps to Reproduce:
1. Go to sleep (suspend)
2. Wake up

Actual results:
Wifi cannot reconnect. Even disabling (hardware switch) and re-enabling does not bring it back.  I have to shutdown (or hibernate), and then it works.

Also discovered that when it wakes up from sleep, it couldn't even see the 
access point it was using before (according to Network Manager...or maybe it 
had just removed it from the list since it couldn't connect).  Disabling the 
wireless by both software and hardware switches solved the visibility problem, 
but did not resolve the connection issue.

Expected results:
Wifi reconnects.

lspci:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 07)
Comment 1 Stanislaw Gruszka 2013-06-21 09:24:38 EDT
"fail to flush all tx fifo queues" problem after resume from suspend.
Comment 2 Stanislaw Gruszka 2013-08-01 05:01:31 EDT
Does the problem happen on updated kernel 3.10 ?
If it does, I'll request you for some more debugging information.
Comment 3 Joshua Kugler 2013-08-01 11:31:43 EDT
How might I go about installing said kernel?  I have fedora-updates and fedora-updates-testing enabled and I do not have the option to install a 3.10 kernel.

Thanks!
Comment 4 Stanislaw Gruszka 2013-08-02 03:48:52 EDT
Oh, seems repositories are not updated. You can download kernel from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=440211
and install by "rpm -ivh kernel*.rpm"
Comment 5 Joshua Kugler 2013-08-02 11:58:11 EDT
I downloaded the kernel and installed

kernel-3.10.4-100.fc18.x86_64.rpm
kernel-modules-extra-3.10.4-100.fc18.x86_64.rpm

After a sleep, the wifi comes up just fine! Woohoo! Thank you!
Comment 6 Joshua Kugler 2013-08-02 12:19:59 EDT
I put this through several cycles, and it came back every time. I think we can mark this one as resolved, pending new kernel.

Thanks!
Comment 7 Joshua Kugler 2013-08-06 11:56:06 EDT
I just realized: I am still running 3.9.10-200, which is working for some reason. It appears the kernel-3.10.4-100.fc18 package didn't set itself as the default to boot when it was installed.

I went through several cycles with the 3.10.4-100 kernel and it worked fine. Just so you know. :)

Note You need to log in before you can comment on or make changes to this bug.