Bug 976211 - The make_scanner from simplejson._speedups not being able to handle unicode strings containing floating point numbers with more than 1 decimal place - Unable to run buildbot master Periodic scheduler
The make_scanner from simplejson._speedups not being able to handle unicode ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-simplejson (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Python Maintainers
Red Hat Satellite QA List
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 03:01 EDT by Jan Friesse
Modified: 2016-07-14 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-14 11:14:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Friesse 2013-06-20 03:01:05 EDT
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
python-simplejson-2.0.9-3.1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
>>> from simplejson import decoder
 >>> dec = decoder.JSONDecoder()
 >>> dec.decode('1322162939.8104999')
1322162939.8104999
 >>> dec.decode(u'1322162939.8104999')
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File "/usr/lib/pymodules/python2.6/simplejson/decoder.py", line 338, 
in decode
     raise ValueError(errmsg("Extra data", s, end, len(s)))
ValueError: Extra data: line 1 column 17 - line 1 column 18 (char 17 - 18)
 >>> dec.decode(u'1322162939.8')
1322162939.8

Actual results:
Exception

Expected results:
Properly parsed value

Additional info:
Found by trying to execute buildbot master Periodic scheduler on fully updated RHEL 6.4 box. See problem

http://sourceforge.net/mailarchive/forum.php?thread_name=4ED30174.1050606%40ranzer.geek.nz&forum_name=buildbot-devel

Update to fc16 package (python-simplejson-2.1.6-1.fc16.x86_64.rpm) solves problem.
Comment 2 RHEL Product and Program Management 2013-10-13 19:27:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Bohuslav "Slavek" Kabrda 2014-02-14 07:47:32 EST
Note: this is fixed by upstream patch http://code.google.com/p/simplejson/source/detail?r=177.
Comment 4 Petr Viktorin 2016-07-14 11:14:14 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

I suggest using "json" (from the standard library in Python 2.6+) instead of simplejson.

Note You need to log in before you can comment on or make changes to this bug.