Bug 976433 - can't be rebuild devtoolset-2-swt-chart-0.8.0-9.el6 since missing br tycho
can't be rebuild devtoolset-2-swt-chart-0.8.0-9.el6 since missing br tycho
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: doc-User_Guide (Show other bugs)
DTS 2.0 RHEL 6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: Jaromir Hradilek
:
: 976584 (view as bug list)
Depends On: 976584
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 10:48 EDT by Levente Farkas
Modified: 2013-09-17 03:11 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Clarification that Eclipse rebuilds on RHEL6 are unsupported due to build environment complexity. Documentation of environment setup and steps Red Hat used for bootstrap builds. Reason: End user request. Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 09:13:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2013-06-20 10:48:35 EDT
it seems tycho missing from rhel6 to be able to rebuild devtoolset-2-swt-chart
Comment 8 Matt Newsome 2013-06-24 07:39:03 EDT
End-user rebuilds of Eclipse RPMs requires a very specific environment which is unfortunately not easily reproducible with a RHEL6 system. Consequently bootstrap builds of Red Hat Developer Toolset Eclipse on RHEL6 systems is unsupported.

For the majority of Red Hat Developer Toolset users the use case is to either use Eclipse (perhaps with some additional plugins) to develop third party software, or perhaps develop their own plugins. Consequently we have focused on these use cases in our release of Eclipse in Red Hat Developer Toolset and the corresponding documentation.

While we still encourage against rebuilding core components of Red Hat Developer Toolset's Eclipse build due to the complexities setting up the build environment, we understand some users may wish to. Consequently, we intend to add some extra documentation to the beta release of Red Hat Developer Toolset 2.0 in a forthcoming update. 

This documentation will clarify that bootstrap builds on RHEL6 are unsupported and will also indicate the packages and versions we used when we built DTS Eclipse together with the steps we used to do so. This is provided purely for information to the user.
Comment 9 Levente Farkas 2013-06-25 09:31:59 EDT
dare i ask for this documentation?
may be i'm much more advanced user then you can assume:-)

anyway what i'd love to include those packages in rhel6 which are not in the base packages. i mean eg: apache-commons-codec is not in the base packages. so there is no need for scl in this case. i'd be much easier to add to the base os rather than scl-ed "devtoolset-2-" package it.

here we mainly talk about java packages. is there any place where you have all these java packages compiled for rhel6 with all it's dependencies? eg the most important maven3 for rhel6 (and may be a coressponding jpackage-utils)!?

thanks in advance.
Comment 10 Alexander Kurtakov 2013-06-25 09:39:43 EDT
The problem is that in order to build apache-commons-codec one needs the whole Maven stack and that's too big chunk to be added to RHEL 6.
Comment 11 Levente Farkas 2013-06-25 11:10:35 EDT
of course i know it;-)
that's why i ask for it.
is there a list of f19 packages which installed on a rhel6 system make it possible to build these packages?
Comment 12 Matt Newsome 2013-06-27 14:59:06 EDT
We're on track to update documentation in a future update to the Red Hat Developer Toolset 2.0 beta, which will include the information referred to in c8.
Comment 19 Matt Newsome 2013-07-19 03:57:27 EDT
*** Bug 976584 has been marked as a duplicate of this bug. ***
Comment 26 Levente Farkas 2013-09-10 12:07:32 EDT
is it released? i can't find dts 2 in release!
Comment 27 Brian Gollaher 2013-09-10 12:37:22 EDT
DTS 2.0 has not been released yet.  Please look for Red Hat to announce the release.
Comment 28 Thomas Oulevey 2013-09-16 09:52:33 EDT
"While we still encourage against rebuilding core components of Red Hat Developer Toolset's Eclipse build due to the complexities setting up the build environment, we understand some users may wish to. Consequently, we intend to add some extra documentation to the beta release of Red Hat Developer Toolset 2.0 in a forthcoming update. "

Now DTS 2.0 has been released could you guide us on the rebuilding ? I couldn't find any info in the doc.

cheers,
-- 
Thomas.
Comment 29 Alexander Kurtakov 2013-09-17 02:10:51 EDT
Hi Thomas,
We have a dedicated section for that in the user guide https://access.redhat.com/site/documentation/en-US/Red_Hat_Developer_Toolset/2/html/User_Guide/chap-Eclipse.html#sect-Eclipse-Install-Rebuild . With that said it requires a fair amount of work on your side to get it going.
Comment 30 Thomas Oulevey 2013-09-17 03:11:38 EDT
Thanks for the pointer, I was probably not awake when I look at the user guide !!

cheers,
-- 
Thomas

Note You need to log in before you can comment on or make changes to this bug.