Bug 976446 - kdump fails to start on initial installation
kdump fails to start on initial installation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks: 1067800
  Show dependency treegraph
 
Reported: 2013-06-20 11:07 EDT by Joey Boggs
Modified: 2014-02-21 00:51 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When booting the iso the kdump services failed to start which caused confusion. This has been resolved by adding an ovirt-kdump service wrapper to prevent confusing errors.
Story Points: ---
Clone Of:
: 1067800 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:42:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached the boot console screen (25.35 KB, image/png)
2013-06-21 01:39 EDT, haiyang,dong
no flags Details

  None (edit)
Description Joey Boggs 2013-06-20 11:07:26 EDT
Description of problem:
When booting the iso the kdump services fails to start and this may confuse the user.

Steps to Reproduce:
1. Boot ISO

Actual results:
Boot log or console shows [FAILED] on kdump start


Expected results:
kdump should not start or should not fail.

Additional info:
Comment 1 Joey Boggs 2013-06-20 11:11:06 EDT
http://gerrit.ovirt.org/15962

adds a wrapper script and only starts if a kdump configuration is persisted
Comment 2 haiyang,dong 2013-06-21 01:39:45 EDT
Created attachment 763654 [details]
attached the boot console screen

Can reproduce this bug on build rhev-hypervisor6-6.4-20130528.0.el6_4
Please see the attached screenshot for boot console to check this issue.
Comment 6 Cheryn Tan 2013-11-07 19:30:51 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 haiyang,dong 2013-12-10 03:39:21 EST
Test version:
rhevh-6.5-20131031.1.0.iso
ovirt-node-3.0.1-7.el6

Still could see kdump start issue on boot console screen, so this bug wasn't fix in ovirt-node-3.0.1-7.el6. need to re-assigned it.
Comment 8 Fabian Deutsch 2014-01-07 13:30:23 EST
(In reply to haiyang,dong from comment #7)
> Test version:
> rhevh-6.5-20131031.1.0.iso
> ovirt-node-3.0.1-7.el6

I could also reproduce it with
rhevh-6.5-20131031.1.0.iso
but
rhevh-6.5-20131220.0.iso
is fine.
Comment 9 haiyang,dong 2014-01-08 03:12:37 EST
Test version:
rhevh-6.5-20131220.0.iso
ovirt-node-3.0.1-13.el6_5.noarch

Now see ovirt-kdump start success on boot console screen, so this bug has been fixed, change the status into "verified"
Comment 11 errata-xmlrpc 2014-01-21 14:42:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.