Bug 976453 - Missing gpg feature [NEEDINFO]
Missing gpg feature
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fwknop (Show other bugs)
20
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Jelen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 11:25 EDT by Ulrich Drepper
Modified: 2015-06-10 15:16 EDT (History)
6 users (show)

See Also:
Fixed In Version: fwknop-2.6.5-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-05 19:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jjelen: needinfo? (bugzilla.30.miller_2555)


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2013-06-20 11:25:19 EDT
Description of problem:
fwknop has support for GPG keys by using the gpgme package.  The problem is that the .spec file in the current version doesn't have gpgme-devel as a BuildRequire and therefore the configure script won't find the library.

Version-Release number of selected component (if applicable):
2.0.4-1

How reproducible:
always

Steps to Reproduce:
1.set up fwknop with gpg keys
2.try to use it
3.

Actual results:
Error message about unsupported feature

Expected results:
Working gpg support

Additional info:

In lib/fko_encryption.c in function fko_set_gpg_recipient (among others) there is #ifdef HAVE_LIBGPGME.  Just adding

BuildRequires: gpgme-devel

fixes this.
Comment 1 Ulrich Drepper 2013-11-01 17:52:29 EDT
Could you please just add the one little change?  It still is broken in F20.  If the problem is that I did not provide a patch let me know.  But it's really just a matter of adding gpgme-devel to the BuildRequires line.
Comment 2 Ulrich Drepper 2013-12-01 12:10:47 EST
Still not done, I once again had to compile the version myself.  It's a really simple change.  Do you have a problem with this?  Is the build environment even more restricted?  Maybe in addition to gpgme-devel you also have to add gpg.  So:

-BuildRequires: libpcap-devel iptables systemd
+BuildRequires: libpcap-devel iptables systemd gpgme-devel gpg
Comment 3 Ben Reedy 2014-10-25 13:40:44 EDT
Bug is still occurring as of version 2.5.1-1.fc20
GPG functionality worked after adding Ulrich's fix to the spec file and building myself.
Comment 4 bugzilla.30.miller_2555 2015-03-11 21:35:11 EDT
Ditto on this -- still outstanding in F22, and fix doesn't appear in rawhide. Since still marked "NEW', maybe it was just lost in the shuffle -- is Jakub the appropriate assignee (to QA)? Thx
Comment 5 Jakub Jelen 2015-04-07 07:13:52 EDT
Sorry, I did miss this bugzilla during last update(s).

I pushed this feature into rawhide and will be glad for some testing if it does what it should.
http://koji.fedoraproject.org/koji/taskinfo?taskID=9427870

If so, please let me know that I can post it also into other branches. I tested only basic functionality.
Comment 6 Fedora Update System 2015-05-25 10:40:44 EDT
fwknop-2.6.5-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fwknop-2.6.5-2.fc22
Comment 7 Fedora Update System 2015-05-25 11:22:19 EDT
fwknop-2.6.5-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fwknop-2.6.5-2.fc21
Comment 8 Fedora Update System 2015-05-26 07:37:25 EDT
fwknop-2.6.5-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/fwknop-2.6.5-2.el7
Comment 9 Ulrich Drepper 2015-05-26 09:18:19 EDT
I can confirm it works now.  Tested on F22.
Comment 10 Fedora Update System 2015-05-26 17:27:33 EDT
Package fwknop-2.6.5-2.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fwknop-2.6.5-2.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-6411/fwknop-2.6.5-2.el7
then log in and leave karma (feedback).
Comment 11 Fedora End Of Life 2015-05-29 05:08:05 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora Update System 2015-06-05 19:55:11 EDT
fwknop-2.6.5-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-06-05 20:02:53 EDT
fwknop-2.6.5-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2015-06-10 15:16:21 EDT
fwknop-2.6.5-2.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.