Bug 976556 - [RFE] Installer with signo should default to hostname if FQDN is not available
[RFE] Installer with signo should default to hostname if FQDN is not available
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Garik Khachikyan
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 15:11 EDT by Bryan Kearney
Modified: 2015-01-04 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-06-20 15:11:30 EDT
When installing satellite6 on a box with a hostname called "sat6" then facter.fqdn returns null. This causes the foreman signo integration to not work.

This RFE is to have the installation fall back to hostname if there is no FQDN. Looking at https://bugzilla.redhat.com/show_bug.cgi?id=976460 we may want to also handle ip addresses.
Comment 1 RHEL Product and Program Management 2013-06-20 15:23:48 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Marek Hulan 2013-07-01 07:40:19 EDT
https://github.com/Katello/katello-installer/pull/37 merged in https://github.com/Katello/katello-installer/commit/f71e590ffb3fb415f49b631c42ba63b8a2be7ee6 

The other PR was declined however not needed in order to resolve this bug.
Comment 8 Mike McCune 2014-01-16 16:16:57 EST
removing signo component and moving these bugs to 'Infrastructure'
Comment 11 Bryan Kearney 2014-04-24 13:11:12 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 12 Bryan Kearney 2014-04-24 13:12:10 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.