Bug 976575 - RHEL5 repositories contain yum metadata in the distribution files in pulp
RHEL5 repositories contain yum metadata in the distribution files in pulp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Og Maciel
:
Depends On: 976579
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 16:49 EDT by Mike McCune
Modified: 2014-01-27 09:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 976579 (view as bug list)
Environment:
Last Closed: 2013-07-18 17:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-06-20 16:49:05 EDT
When syncing a RHEL5 repository from Red Hat's CDN we are getting extra yum metadata files included in the distribution files which causes issues with clients using the repo during kickstart.  Examples:

If you look at the files in the distribution on a RHEL6 synced repo from Red Hat's CDN you will see just the standard kickstart tree files:

# pulp-admin rpm repo content distribution --repo-id=SimpleOrg-Dev_Env-PublishedRHEL6Composite32-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_i386_6Server
Id:            ks-Red Hat Enterprise Linux-Server-6.4-i386
Family:        Red Hat Enterprise Linux
Architecture:  i386
Variant:       Server
Storage Path:  /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-i386

Files:
  Filename:       vmlinuz
  Relative Path:  images/pxeboot/vmlinuz

  Filename:       boot.iso
  Relative Path:  images/boot.iso

  Filename:       product.img
  Relative Path:  images/product.img

  Filename:       install.img
  Relative Path:  images/install.img

  Filename:       initrd.img
  Relative Path:  images/pxeboot/initrd.img

if you look at a repo for RHEL5 and the associated distribution files you will note there are also yum metadata files within the distro itself:

# pulp-admin rpm repo content distribution --repo-id=SimpleOrg-Dev_Env-PublishedRHEL5Composite32-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_i386_5Server
Id:            ks-Red Hat Enterprise Linux Server-5.9-i386
Family:        Red Hat Enterprise Linux Server
Architecture:  i386
Variant:       None
Storage Path:  /var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux Server-5.9-i386

Files:
  Filename:       productid.gz
  Relative Path:  Server/repodata/productid.gz

  Filename:       diskboot.img
  Relative Path:  images/diskboot.img

  Filename:       stage2.img
  Relative Path:  images/stage2.img

  Filename:       9fc4a1f004bad3d7a8a16399edc11e60c3dc4912-primary.sqlite.bz2
  Relative Path: 
Server/repodata/9fc4a1f004bad3d7a8a16399edc11e60c3dc4912-primary.sqlite.bz2

  Filename:       initrd.img
  Relative Path:  images/pxeboot/initrd.img

  Filename:      
8720e1f5fe59ceb1d90e90da61ee861b34e56ee8-comps-rhel5-server-core.xml.gz
  Relative Path: 
Server/repodata/8720e1f5fe59ceb1d90e90da61ee861b34e56ee8-comps-rhel5-server-core.xml.gz

  Filename:       495a76c854fa47bcb4daccc3877ae3fd2c2a9ed6-updateinfo.xml.gz
  Relative Path: 
Server/repodata/495a76c854fa47bcb4daccc3877ae3fd2c2a9ed6-updateinfo.xml.gz

  Filename:       boot.iso
  Relative Path:  images/boot.iso

  Filename:       vmlinuz
  Relative Path:  images/pxeboot/vmlinuz

  Filename:       31d97c447f16a218cb7bac4dc8d12c6711eb4e2a-filelists.xml.gz
  Relative Path: 
Server/repodata/31d97c447f16a218cb7bac4dc8d12c6711eb4e2a-filelists.xml.gz

  Filename:       080102c692f8ba486404da576d252b28fa228c4d-other.sqlite.bz2
  Relative Path: 
Server/repodata/080102c692f8ba486404da576d252b28fa228c4d-other.sqlite.bz2

  Filename:       68c8d4457c0e30d0821c2d73abc7e86b55c9e005-filelists.sqlite.bz2
  Relative Path: 
Server/repodata/68c8d4457c0e30d0821c2d73abc7e86b55c9e005-filelists.sqlite.bz2

  Filename:      
6726c7824dcc21ad36ab03ba45e86dc3f20e06c4-comps-rhel5-server-core.xml
  Relative Path: 
Server/repodata/6726c7824dcc21ad36ab03ba45e86dc3f20e06c4-comps-rhel5-server-core
.xml

  Filename:       d2a3808849268bd5afe495562f5a9d0d94a3110e-other.xml.gz
  Relative Path: 
Server/repodata/d2a3808849268bd5afe495562f5a9d0d94a3110e-other.xml.gz

  Filename:       repomd.xml
  Relative Path:  Server/repodata/repomd.xml

  Filename:       ae30a5b8654067f050546bb9b492343c7fd36c7b-primary.xml.gz
  Relative Path: 
Server/repodata/ae30a5b8654067f050546bb9b492343c7fd36c7b-primary.xml.gz
Comment 2 Michael Hrivnak 2013-06-20 17:41:30 EDT
Assigning this back to you because I've created a bug against Pulp, which is where we will handle this fix.

https://bugzilla.redhat.com/show_bug.cgi?id=976579
Comment 3 Og Maciel 2013-06-29 21:33:28 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-compute-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10014-1.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-18.el6sat.noarch
* katello-all-1.4.2-18.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-18.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-18.el6sat.noarch
* katello-glue-candlepin-1.4.2-18.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-18.el6sat.noarch
* katello-glue-pulp-1.4.2-18.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.3-0.1.beta.el6sat.noarch
* pulp-selinux-2.1.3-0.1.beta.el6sat.noarch
* pulp-server-2.1.3-0.1.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch
Comment 4 Mike McCune 2013-07-18 17:21:49 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.