Bug 9766 - linuxconf always segfaults
linuxconf always segfaults
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 15:43 EST by corth
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description corth 2000-02-24 15:43:56 EST
linuxconf is stripped, but gdb shows the crash here:

Program received signal SIGSEGV, Segmentation fault.
0x8a648 in BUTTONS_INFO::setcursor ()

This is a fresh install on a sun4c machine.

I tried running in console without X, still crashes but doesn't report a
symbol location.

Chris
Comment 1 Nalin Dahyabhai 2000-03-06 09:31:59 EST
Try refreshing your kernel and linuxconf versions from Raw Hide.  We've had
another bug report in linuxconf that can no longer be reproduced on the latest
builds.
Comment 2 corth 2000-03-06 13:11:59 EST
Hmmm.  Went to 2.2.14-5.  linuxconf still not working, and I'm getting some
pretty frightening kernel instabilities that seem to be associated with amd (for
about 5 mins. following an automount or unmount of a nfs filesystem EVERY user
command SEGFAULTS; a shell I have open as root remains ok).  If I can't find
anything I did wrong I'll probably be filing some separate reports soon....
Comment 3 Nalin Dahyabhai 2000-03-07 11:18:59 EST
Yikes.  Any chance I can get you to add a backtrace to this report?  By that, I
mean firing up /bin/linuxconf using gdb (by running "gdb /bin/linuxconf", and
typing "run"), and then using gdb's "bt" command when it dies?  I'm looking at
the code for BUTTONS_INFO::setcursor right now and it looks fairly safe, so I
suspect that the calling function might be passing in bogus data.
Comment 4 corth 2000-03-07 11:34:59 EST
FWIW:
#0  0x8a64Program received signal SIGSEGV, Segmentation fault.
0x8a648 in BUTTONS_INFO::setcursor ()
(gdb) bt
#1  0x8a708 in BUTTONS_INFO::draw ()
#2  0x92d90 in DIALOG::draw ()
#3  0x97ccc in DIALOG::showterm ()
#4  0x936dc in DIALOG::show ()
#5  0x93724 in DIALOG::edit ()
#6  0x91f8c in dialog_textbox ()
#7  0x39248 in notice_show ()
#8  0x38810 in linuxconf_main ()
#9  0x369bc in main ()
#10 0xe017b578 in __libc_start_main () at ../sysdeps/generic/libc-start.c:122

I'm thinking that if I grab the SRPM and make it recompile -g, that the above
will be more helpful (if the crash still happens at all).  If I run in console
gdb dies at the SEGFAULT too.
Comment 5 Brent Fox 2002-06-05 12:14:26 EDT
Closing because we don't ship linuxconf anymore
Comment 6 Red Hat Bugzilla 2006-02-21 13:47:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.