Bug 976635 - Managedsave/save failed with unable to execute QEMU command 'getfd'
Managedsave/save failed with unable to execute QEMU command 'getfd'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Krempa
Virtualization Bugs
: Upstream
Depends On: 976632
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 00:46 EDT by zhenfeng wang
Modified: 2014-04-04 16:57 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976632
Environment:
Last Closed: 2014-04-04 16:57:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Dave Allan 2013-06-27 04:31:38 EDT
Dan, does OpenStack set relabel='no' ?
Comment 4 Daniel Berrange 2013-06-27 05:42:25 EDT
No, openstack relies on completely dynamic selinux labelling. This bug doesn't seem to be related to openstack in any case - the initial report says the reporter is manually adding the static selinux label
Comment 5 Dave Allan 2013-06-27 06:08:06 EDT
(In reply to Daniel Berrange from comment #4)
> No, openstack relies on completely dynamic selinux labelling. This bug
> doesn't seem to be related to openstack in any case - the initial report
> says the reporter is manually adding the static selinux label

Indeed, it's not related to OpenStack, I just wanted to make sure that any changes we make as a result of it won't affect OpenStack.  (I have the same question about oVirt.)
Comment 6 Michal Skrivanek 2013-07-01 09:14:45 EDT
should not be related to oVirt either, as far as I know
Comment 8 Peter Krempa 2013-07-08 09:14:54 EDT
Fixed upstream by:
commit 2ce63c161111c6d813130f850639d1548d80c3fe
Author: Peter Krempa <pkrempa@redhat.com>
Date:   Tue Jul 2 18:34:58 2013 +0200

    selinux: Always generate imagelabel
    
    The imagelabel SELinux label was only generated when relabeling was
    enabled. This prohibited labeling of files created by libvirt that need
    to be labeled even if relabeling is turned off.
    
    The only codepath this change has direct impact on is labeling of FDs
    passed to qemu which is always safe in current state.
Comment 10 Jiri Denemark 2013-07-08 10:31:40 EDT
We decided not to rebase libvirt in RHEL 6.5 to avoid stability issues
we faced in 6.4. This bug has already been fixed upstream but it is
considered unsuitable for backporting to RHEL 6.5 because at least one
of the following conditions is met:

- this bug requires new API(s), which we cannot introduce without
  rebasing libvirt
- the patches required to address this bug are complex or invasive
  causing the backport to be too risky
- this bug is not important enough to justify backporting non-trivial
  patches for it

Thus I'm pushing this bug to RHEL 6.6 (and setting Upstream keyword to
indicate we have patches upstream) for now. If you don't agree with
this resolution, please, give us reasons which you think are strong
enough for us to reevaluate the decision not to backport patches for
this bug.
Comment 13 RHEL Product and Program Management 2014-04-04 16:57:47 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.