Bug 976647 - createmodule.sh wrongly converts XDG_DATA_DIRS
createmodule.sh wrongly converts XDG_DATA_DIRS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: environment-modules (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 01:52 EDT by Bohuslav "Slavek" Kabrda
Modified: 2013-09-04 11:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: environment-modules-3.2.10-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 11:44:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
createmodule.py (5.88 KB, text/plain)
2013-08-29 17:20 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Bohuslav "Slavek" Kabrda 2013-06-21 01:52:33 EDT
Using the /usr/share/Modules/bin/createmodule.sh on a file that contains XDG_DATA_DIRS [1] variable I get:

setenv		XDG_DATA_DIRS	a:

when in fact I should get

prepend-path	XDG_DATA_DIRS	a:

since this is a normal list of colon-separated paths. This is caused by assumption that all path lists will end with "PATH". This could IMO be extended also on variables ending "DIRS" as in the example above.

[1] http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html#variables
Comment 1 Orion Poplawski 2013-08-29 17:20:01 EDT
Created attachment 791957 [details]
createmodule.py

Can you give this a try?
Comment 2 Bohuslav "Slavek" Kabrda 2013-09-04 04:31:49 EDT
Yes, that works like a charm, thanks!

Note You need to log in before you can comment on or make changes to this bug.