Bug 976681 - Gear got partially deleted on INT
Gear got partially deleted on INT
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
Depends On:
  Show dependency treegraph
Reported: 2013-06-21 03:50 EDT by Meng Bo
Modified: 2015-05-14 20:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-22 11:17:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-06-21 03:50:54 EDT
Description of problem:
Eventually get my jenkins server deletion failed, with following error.

>Deleting application 'jenkins' ... Application is currently busy performing another operation. Please try again in a minute.

When I tried to delete it again, got the app does not exist for my domain,

>Application 'jenkins' not found for domain 'bmengc9int'

But when I trying to create jenkins server with the same name, it said the app with name jenkins already exist.

>Creating application 'jenkins' ... The supplied application name 'jenkins' already exists

From a domain show, I cannot get the app with name jenkins
>rhc domain show
Applications in bmengc9int domain

  jbas1s @ http://jbas1s-bmengc9int.int.rhcloud.com/ (uuid: 51c3fc5c6cec0e279e000091)
    Created: 3:10 AM
    Gears:   1 (defaults to small)
    Git URL: ssh://51c3fc5c6cec0e279e000091@jbas1s-bmengc9int.int.rhcloud.com/~/git/jbas1s.git/
    SSH:     51c3fc5c6cec0e279e000091@jbas1s-bmengc9int.int.rhcloud.com

    jbossas-7 (JBoss Application Server 7)
      Scaling: x1 (minimum: 1, maximum: available) on small gears

    haproxy-1.4 (OpenShift Web Balancer)
      Gears: Located with jbossas-7

  py27s @ http://py27s-bmengc9int.int.rhcloud.com/ (uuid: 51c3f64e6cec0ef8480000c0)
    Created: 2:44 AM
    Gears:   2 (defaults to small)
    Git URL: ssh://51c3f64e6cec0ef8480000c0@py27s-bmengc9int.int.rhcloud.com/~/git/py27s.git/
    SSH:     51c3f64e6cec0ef8480000c0@py27s-bmengc9int.int.rhcloud.com

    python-2.7 (Python 2.7)
      Scaling: x2 (minimum: 2, maximum: available) on small gears

    haproxy-1.4 (OpenShift Web Balancer)
      Gears: Located with python-2.7

You have 2 applications in your domain.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Create jenkins server and delete it.

Actual results:
The jenkins app got a partially deleted. And I cannot create app with that name.

Expected results:
Gear should be deleted completely.

Additional info:
I can create jenkins server with other name successfully, that means the gear name part left on the mongodb.
Comment 1 Abhishek Gupta 2013-07-08 15:24:36 EDT
Several fixes were made in the last release to address some of the underlying issues. The application should now have been cleared and if not, you should be able to delete the application using UI/REST/CLI.
Comment 2 Meng Bo 2013-07-09 05:38:50 EDT
Will check the issue when INT get back.
Comment 3 Meng Bo 2013-07-10 04:42:33 EDT
Tried several times on INT with same operations, app can be created after the one with same name was deleted.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.