This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 976737 - rpcidmapd service came to fail starting since updated to nfs-utils-1.0.9-60.el5.
rpcidmapd service came to fail starting since updated to nfs-utils-1.0.9-60.el5.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.9
All Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 06:33 EDT by kyoneyama
Modified: 2013-10-15 15:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 15:24:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kyoneyama 2013-06-21 06:33:45 EDT
Description of problem:

rpcidmapd service came to fail starting since updated from nfs-utils-1.0.9-54.el5 to nfs-utils-1.0.9-60.el5.

In my customer’s environment, there is no problem to start rpcidmapd service. 
However, because of the update, Domain option is disabled and the service is failed to start since the machine host name is not specified in FQDN.


  rpc.idmapd: Unable to create name to user id mappings [失敗]
  rpc.idmapd[2119]: libnfsidmap: Unable to determine a default nfsv4 domain; consider specifying one in idmapd.conf」

The format of /etc/idmap.conf has changed since nfs-utils-1.0.9-60.el5,
and Domain option is commented out by default.
It seems that the file was imported from RHEL6.

Documents don't have explanation about this change.

It is thought that this problem can happen in any system if setting non-FQDN hostname.
I request to make Domain option available by default as the former setting.


Version-Release number of selected component (if applicable):

  nfs-utils-1.0.9-60.el5 or later

How reproducible:

  It always occurs if it applies to a configuration.

Steps to Reproduce:
1. Set non-FQDN hostname.
2. Update nfs-utils from 1.0.9-54.el5 to nfs-utils-1.0.9-60.el5.
3. Start rpcidmapd service(`service rpcidmapd start`)


Actual results:
  # service rpcidmapd start
  Starting RPC idmapd                     [OK]

Expected results:

  # service rpcidmapd start
  Starting RPC idmapd                     [OK]

Additional info:
Comment 2 Andrius Benokraitis 2013-10-15 15:24:38 EDT
No additional minor releases are planned for Production Phase 2 in Red Hat Enterprise Linux 5, and therefore Red Hat is closing this bugzilla as it does not meet the inclusion criteria as stated in:
https://access.redhat.com/site/support/policy/updates/errata/#Production_2_Phase

Note You need to log in before you can comment on or make changes to this bug.