Bug 97681 - updfstab does not recognize NEC USB floppy drive
updfstab does not recognize NEC USB floppy drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 06:04 EDT by diego.santacruz
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 00:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 2003-06-19 06:04:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The /etc/updfstab.conf.default does not recognize my NEC USB Floppy drive as
such and therefore does not perform the appropriate settings.

The floppy ID as recognized by the SCSI emulation of usb-storage is:

scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: NEC       Model: USB UF000x        Rev: 1.50
  Type:   Direct-Access                      ANSI SCSI revision: 02






Version-Release number of selected component (if applicable):
kudzu-0.99.99-1

How reproducible:
Always

Steps to Reproduce:
1. Plug the USB Floppy drive
2.
3.
    

Actual Results:  Nothing is set up in /etc/fstab for the floppy drive

Expected Results:  updfstab should include the following entry in /etc/fstab

/dev/sda  /mnt/floppy    auto    noauto,owner,kudzu 0 0


Additional info:

I added the following to the end of the /etc/updfstab.conf file and the USB
floppy is recognized by updfstab:

device floppy {
    match floppy "USB UF"
}

(don't know if it is the proper fix but it works for me).

BTW, why is that not all devices of the floppy class are recognized as floppy
drives (as is the case for cdrom class)
Comment 1 Bill Nottingham 2003-10-08 00:17:39 EDT
Added in 1.1.32-1.

Note You need to log in before you can comment on or make changes to this bug.