Bug 976895 - get 500 httpd error code when trying to create a php-5.5 app in Origin using vagrant.
get 500 httpd error code when trying to create a php-5.5 app in Origin using ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 15:42 EDT by Peter Ruan
Modified: 2015-05-14 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:21:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-06-21 15:42:49 EDT
Description of problem:

get 500 httpd error code when trying to create a php-5.5 app in Origin using vagrant.

Version-Release number of selected component (if applicable):

latest vagrant install 

How reproducible:


Steps to Reproduce:
1. install origin via vagrant following the instructions from here:  http://openshift.github.io/origin/file.install_origin_using_vagrant.html
2. 
3.

Actual results:
Reference ID: 99d4e618ab3fac878da54e7ce437c72d - Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.
  /usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.10.1/lib/openshift/mcollective_application_container_proxy.rb:2632:in `parse_result'
  /usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.10.1/lib/openshift/mcollective_application_container_proxy.rb:399:in `block in create'
  /usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.10.1/lib/openshift/mcollective_application_container_proxy.rb:394:in `each'
  /usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.10.1/lib/openshift/mcollective_application_container_proxy.rb:394:in `create'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/gear.rb:77:in `create_gear'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/pending_app_op_group.rb:204:in `block in execute'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/pending_app_op_group.rb:155:in `each'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/pending_app_op_group.rb:155:in `execute'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/application.rb:1253:in `run_jobs'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/application.rb:488:in `block in add_features'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/application.rb:1295:in `run_in_application_lock'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/application.rb:486:in `add_features'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/models/application.rb:173:in `create_app'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/app/controllers/applications_controller.rb:98:in `create'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/base.rb:167:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rendering.rb:10:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/callbacks.rb:18:in `block in process_action'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:481:in `block in _run__902692301262035897__process_action__1341013437616539593__callbacks'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_358'
  /usr/share/gems/gems/openshift-origin-controller-1.10.1/lib/openshift/controller/action_log.rb:34:in `set_logged_request'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_358'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:403:in `_run__902692301262035897__process_action__1341013437616539593__callbacks'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `__run_callback'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:81:in `run_callbacks'
  /usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/callbacks.rb:17:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rescue.rb:29:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications.rb:123:in `block in instrument'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications.rb:123:in `instrument'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/base.rb:121:in `process'
  /usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/rendering.rb:45:in `process'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal.rb:203:in `dispatch'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal.rb:246:in `block in action'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:73:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:73:in `dispatch'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:36:in `call'
  /usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'
  /usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'
  /usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:612:in `call'
  /usr/local/share/gems/gems/mongoid-3.0.21/lib/rack/mongoid/middleware/identity_map.rb:34:in `block in call'
  /usr/local/share/gems/gems/mongoid-3.0.21/lib/mongoid/unit_of_work.rb:39:in `unit_of_work'
  /usr/local/share/gems/gems/mongoid-3.0.21/lib/rack/mongoid/middleware/identity_map.rb:34:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/etag.rb:23:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/conditionalget.rb:35:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/head.rb:14:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/flash.rb:242:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:210:in `context'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:205:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/cookies.rb:341:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
 /usr/share/gems/gems/rack-1.4.5/lib/rack/conditionalget.rb:35:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/head.rb:14:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/flash.rb:242:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:210:in `context'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:205:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/cookies.rb:341:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `_run__2684633673218565212__call__3406240395839382416__callbacks'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `__run_callback'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:81:in `run_callbacks'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:32:in `call_app'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:16:in `block in call'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/tagged_logging.rb:22:in `tagged'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:16:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/request_id.rb:22:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/methodoverride.rb:21:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/runtime.rb:17:in `call'
  /usr/share/gems/gems/activesupport-3.2.13/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  /usr/share/gems/gems/rack-1.4.5/lib/rack/lock.rb:15:in `call'
  /usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/static.rb:63:in `call'
  /usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
  /usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:143:in `pass'
  /usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:155:in `invalidate'
  /usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:71:in `call!'
  /usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/engine.rb:479:in `call'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/application.rb:223:in `call'
  /usr/share/gems/gems/railties-3.2.13/lib/rails/railtie/configurable.rb:30:in `method_missing'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/request_handler.rb:97:in `process_request'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:521:in `accept_and_process_next_request'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:206:in `start_request_handler'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:171:in `block in handle_spawn_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/utils.rb:470:in `safe_fork'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:166:in `handle_spawn_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:180:in `start'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:129:in `start'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:253:in `block (2 levels) in spawn_rack_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:132:in `lookup_or_add'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:246:in `block in spawn_rack_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:82:in `block in synchronize'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:244:in `spawn_rack_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:137:in `spawn_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
  /usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
  /usr/share/gems/gems/passenger-3.0.21/helper-scripts/passenger-spawn-server:102:in `<main>'
  FAILURE ACTION=ADD_APPLICATION USER_ID=51c4a6856892df2228000001 LOGIN=admin DOMAIN=vagrantorigin Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..
Reference ID: 99d4e618ab3fac878da54e7ce437c72d
                                                                                                                                                                                                                           346,3         86%


Expected results:
success

Additional info:
Comment 1 Abhishek Gupta 2013-11-13 13:45:26 EST
I believe this is now fixed.
Comment 2 Peter Ruan 2013-11-13 13:58:47 EST
verified with one of my older Origin VM

Note You need to log in before you can comment on or make changes to this bug.