Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 976921 - Move oo-admin-cartridge install operations to %posttrans in cartridge RPM specs
Summary: Move oo-admin-cartridge install operations to %posttrans in cartridge RPM specs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Dan Mace
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-21 22:02 UTC by Dan Mace
Modified: 2015-05-14 23:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-22 15:17:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 975794 0 medium CLOSED OPENSHIFT_*_CLUSTER and OPENSHIFT_*_CLUSTER_REMOTE value becomes to blank for scalable jbossas/jbosseap after migration 2021-02-22 00:41:40 UTC

Internal Links: 975794

Description Dan Mace 2013-06-21 22:02:31 UTC
Description of problem:

Within cartridge RPM specfiled, the oo-admin-cartridge command isn't safe to use in %post the way we currently install the package; during %post, the previous RPM version files haven't been cleaned up, meaning we install from a source tree containing a mixture of old and new cartridge version files.

Move the operation to %posttrans, which guarantees the install picks up the final installed package state, and thus only files from the new RPM installation.


Version-Release number of selected component (if applicable):


How reproducible:

Upgrade the RPM of a cartridge whose previous cartridge version contains some set of files to a new version of the RPM and cartridge which removes one of the files from the previous set.


Steps to Reproduce:
1.
2.
3.

Actual results:

The new cartridge version installed into the cartridge repository will contain the files from the previous version which were deleted in the new version.

Expected results:

The new cartridge version to contain only the files present in the new cartridge RPM.

Additional info:

Comment 1 Dan Mace 2013-06-21 22:03:11 UTC
This issue was the root cause of bug 975794.

Comment 2 Jhon Honce 2013-06-21 22:05:18 UTC
Note: Some cartridges already have this change.

Comment 4 openshift-github-bot 2013-07-02 22:22:26 UTC
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/08021b14c6586e1650087914311a698c5665f577
Bug 976921: Move cart installation to %posttrans

Comment 5 openshift-github-bot 2013-07-02 22:22:28 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/e6ad5e5929285e6c761051cb2596b06ece31daa2
Bug 976921: Move cart installation to %posttrans

Comment 6 chunchen 2013-07-03 11:16:52 UTC
It's fixed, verified on devenv_3441, please refer to the following results:

1. SSH into a instance
2. cd /usr/libexec/openshift/cartridges/jbossas
3. vim ./bin/install and Add "echo Test posttrans" to this file
4. Install cartridge
oo-admin-cartridge -a install -s .
5. Check the installed
]# grep "posttrans" /var/lib/openshift/.cartridge_repository/redhat-jbossas/0.0.2/bin/install
echo "Test posttrans"


Note You need to log in before you can comment on or make changes to this bug.