Bug 976939 - (vboxinit) SELinux is preventing /usr/bin/ln from 'create' accesses on the lnk_file kernel-3.9.5-301.fc19.x86_64-x86_64.
SELinux is preventing /usr/bin/ln from 'create' accesses on the lnk_file kern...
Status: CLOSED DUPLICATE of bug 966544
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c67d0f96c4e60b46e1dfbb66fae...
:
: 976949 976957 976958 976959 976960 976961 976962 976964 976965 976966 976967 976968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 20:30 EDT by Moez Roy
Modified: 2013-06-24 01:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 01:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-21 20:30:19 EDT
Description of problem:
SELinux is preventing /usr/bin/ln from 'create' accesses on the lnk_file kernel-3.9.5-301.fc19.x86_64-x86_64.

*****  Plugin catchall_labels (83.8 confidence) suggests  ********************

If you want to allow ln to have create access on the kernel-3.9.5-301.fc19.x86_64-x86_64 lnk_file
Then you need to change the label on kernel-3.9.5-301.fc19.x86_64-x86_64
Do
# semanage fcontext -a -t FILE_TYPE 'kernel-3.9.5-301.fc19.x86_64-x86_64'
where FILE_TYPE is one of the following: NetworkManager_unit_file_t, abrt_unit_file_t, accountsd_unit_file_t, alsa_unit_file_t, amanda_unit_file_t, antivirus_unit_file_t, apcupsd_lock_t, apcupsd_unit_file_t, apmd_lock_t, apmd_unit_file_t, arpwatch_unit_file_t, auditd_unit_file_t, automount_lock_t, automount_unit_file_t, avahi_unit_file_t, bcfg2_unit_file_t, bluetooth_lock_t, bluetooth_unit_file_t, boinc_unit_file_t, chronyd_unit_file_t, cluster_unit_file_t, collectd_unit_file_t, colord_unit_file_t, condor_unit_file_t, condor_var_lock_t, consolekit_unit_file_t, couchdb_unit_file_t, crond_unit_file_t, cupsd_lock_t, cupsd_unit_file_t, denyhosts_var_lock_t, device_t, dhcpd_unit_file_t, dirsrv_var_lock_t, dirsrvadmin_lock_t, dnsmasq_unit_file_t, drbd_lock_t, etc_aliases_t, etc_t, fenced_lock_t, firewalld_unit_file_t, fonts_t, ftpd_lock_t, ftpd_unit_file_t, getty_lock_t, getty_unit_file_t, gssproxy_unit_file_t, httpd_lock_t, httpd_unit_file_t, initrc_state_t, initrc_tmp_t, ipsec_mgmt_lock_t, ipsec_mgmt_unit_file_t, iptables_unit_file_t, iscsi_lock_t, iscsi_unit_file_t, kdump_unit_file_t, keystone_unit_file_t, krb5kdc_lock_t, ksmtuned_unit_file_t, likewise_pstore_lock_t, local_login_lock_t, locale_t, lockdev_lock_t, logrotate_lock_t, logwatch_lock_t, lvm_lock_t, lvm_unit_file_t, mailman_lock_t, mandb_lock_t, mrtg_lock_t, mysqld_unit_file_t, named_unit_file_t, nfsd_unit_file_t, nis_unit_file_t, nova_ajax_unit_file_t, nova_api_unit_file_t, nova_cert_unit_file_t, nova_compute_unit_file_t, nova_console_unit_file_t, nova_direct_unit_file_t, nova_network_unit_file_t, nova_objectstore_unit_file_t, nova_scheduler_unit_file_t, nova_vncproxy_unit_file_t, nova_volume_unit_file_t, nscd_unit_file_t, ntpd_unit_file_t, numad_unit_file_t, nut_unit_file_t, oddjob_unit_file_t, openvswitch_unit_file_t, pkcsslotd_lock_t, pkcsslotd_unit_file_t, pki_ra_lock_t, pki_tomcat_lock_t, pki_tomcat_unit_file_t, pki_tps_lock_t, polipo_unit_file_t, postgresql_db_t, postgresql_lock_t, power_unit_file_t, pppd_lock_t, pppd_unit_file_t, qpidd_var_run_t, quantum_unit_file_t, radiusd_unit_file_t, rhev_agentd_unit_file_t, rhsmcertd_lock_t, ricci_modstorage_lock_t, rngd_unit_file_t, rpcd_unit_file_t, samba_unit_file_t, sanlock_unit_file_t, semanage_read_lock_t, semanage_trans_lock_t, sensord_unit_file_t, shorewall_lock_t, slapd_lock_t, slapd_unit_file_t, sshd_unit_file_t, sssd_unit_file_t, svc_svc_t, svnserve_unit_file_t, swift_unit_file_t, system_cronjob_lock_t, systemd_unit_file_t, tmpfs_t, tomcat_unit_file_t, tor_unit_file_t, usbmuxd_unit_file_t, uucpd_lock_t, var_lock_t, var_run_t, virt_cache_t, virt_lock_t, virtd_unit_file_t, xdm_lock_t, ypbind_unit_file_t. 
Then execute: 
restorecon -v 'kernel-3.9.5-301.fc19.x86_64-x86_64'


*****  Plugin catchall (17.1 confidence) suggests  ***************************

If you believe that ln should be allowed create access on the kernel-3.9.5-301.fc19.x86_64-x86_64 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ln /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                kernel-3.9.5-301.fc19.x86_64-x86_64 [ lnk_file ]
Source                        ln
Source Path                   /usr/bin/ln
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-52.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-21 19:53:02 EDT
Last Seen                     2013-06-21 19:53:02 EDT
Local ID                      f45b8193-a92f-4ca3-a88f-113e47158983

Raw Audit Messages
type=AVC msg=audit(1371858782.348:410): avc:  denied  { create } for  pid=2801 comm="ln" name="kernel-3.9.5-301.fc19.x86_64-x86_64" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1371858782.348:410): arch=x86_64 syscall=symlink success=yes exit=0 a0=7ffff6924ee0 a1=7ffff6924f04 a2=0 a3=3ed2884ec0 items=0 ppid=847 pid=2801 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=ln exe=/usr/bin/ln subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: ln,initrc_t,var_lib_t,lnk_file,create

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-22 06:52:37 EDT
Is this the vbox init script?
Comment 2 Daniel Walsh 2013-06-22 06:53:18 EDT
*** Bug 976949 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2013-06-22 07:07:45 EDT
*** Bug 976958 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2013-06-22 07:07:49 EDT
*** Bug 976957 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2013-06-22 07:09:56 EDT
*** Bug 976960 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2013-06-22 07:09:58 EDT
*** Bug 976959 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Walsh 2013-06-22 07:10:11 EDT
*** Bug 976961 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2013-06-22 07:10:19 EDT
*** Bug 976964 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Walsh 2013-06-22 07:10:20 EDT
*** Bug 976965 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Walsh 2013-06-22 07:10:24 EDT
*** Bug 976962 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Walsh 2013-06-22 07:10:45 EDT
*** Bug 976966 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Walsh 2013-06-22 07:11:05 EDT
*** Bug 976968 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Walsh 2013-06-22 07:11:08 EDT
*** Bug 976967 has been marked as a duplicate of this bug. ***
Comment 14 Miroslav Grepl 2013-06-24 01:36:15 EDT
Yes. We have the bug.
Comment 15 Miroslav Grepl 2013-06-24 01:53:20 EDT

*** This bug has been marked as a duplicate of bug 966544 ***

Note You need to log in before you can comment on or make changes to this bug.