Bug 976955 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the directory B.
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on ...
Status: CLOSED DUPLICATE of bug 976953
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7ed8cf120b8d58c989d0135da14...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 22:57 EDT by Moez Roy
Modified: 2013-06-22 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-22 07:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-21 22:57:47 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the directory B.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed write access on the B directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:user_tmp_t:s0
Target Objects                B [ dir ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-3.6.3-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-201.fc18.x86_64 #1 SMP Tue
                              Jun 11 19:40:51 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-21 14:12:43 PDT
Last Seen                     2013-06-21 14:12:43 PDT
Local ID                      ecfd1a3f-fe1b-4d1d-a9b3-978f1ddea00b

Raw Audit Messages
type=AVC msg=audit(1371849163.226:406): avc:  denied  { write } for  pid=1828 comm="gnome-keyring-d" name="42" dev="tmpfs" ino=20041 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_tmp_t:s0 tclass=dir


type=AVC msg=audit(1371849163.226:406): avc:  denied  { add_name } for  pid=1828 comm="gnome-keyring-d" name="keyring-NmchTo" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_tmp_t:s0 tclass=dir


type=AVC msg=audit(1371849163.226:406): avc:  denied  { create } for  pid=1828 comm="gnome-keyring-d" name="keyring-NmchTo" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1371849163.226:406): arch=x86_64 syscall=mkdir success=yes exit=0 a0=1ec6420 a1=1c0 a2=0 a3=0 items=0 ppid=1827 pid=1828 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=1 tty=(none) comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,xdm_dbusd_t,user_tmp_t,dir,write

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t user_tmp_t:dir { write create add_name };

audit2allow -R
require {
	type xdm_dbusd_t;
}

#============= xdm_dbusd_t ==============
userdom_manage_user_tmp_dirs(xdm_dbusd_t)


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-200.fc18.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-22 07:01:50 EDT

*** This bug has been marked as a duplicate of bug 976953 ***

Note You need to log in before you can comment on or make changes to this bug.