Bug 976967 - SELinux is preventing /usr/bin/cp from 'relabelto' accesses on the directory internal.
SELinux is preventing /usr/bin/cp from 'relabelto' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 976939
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4ae998d3b1423bdd586ec744e90...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 02:03 EDT by Moez Roy
Modified: 2013-06-22 07:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-22 07:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-22 02:03:25 EDT
Description of problem:
SELinux is preventing /usr/bin/cp from 'relabelto' accesses on the directory internal.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that cp should be allowed relabelto access on the internal directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:system_r:initrc_t:s0
Target Context                system_u:object_r:usr_t:s0
Target Objects                internal [ dir ]
Source                        cp
Source Path                   /usr/bin/cp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.17-8.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.6-200.fc18.x86_64 #1 SMP Thu
                              Jun 13 18:56:55 UTC 2013 x86_64 x86_64
Alert Count                   8
First Seen                    2013-06-21 23:02:53 PDT
Last Seen                     2013-06-21 23:02:53 PDT
Local ID                      6e1c5d8c-0d48-41be-9037-cf39cd442fd6

Raw Audit Messages
type=AVC msg=audit(1371880973.154:1249): avc:  denied  { relabelto } for  pid=10030 comm="cp" name="internal" dev="tmpfs" ino=67107 scontext=unconfined_u:system_r:initrc_t:s0 tcontext=system_u:object_r:usr_t:s0 tclass=dir


type=SYSCALL msg=audit(1371880973.154:1249): arch=x86_64 syscall=lsetxattr success=no exit=EACCES a0=12c0b10 a1=7ffffc2f9d70 a2=12c13e0 a3=1b items=0 ppid=10024 pid=10030 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=2 tty=pts0 comm=cp exe=/usr/bin/cp subj=unconfined_u:system_r:initrc_t:s0 key=(null)

Hash: cp,initrc_t,usr_t,dir,relabelto

audit2allow

#============= initrc_t ==============
allow initrc_t usr_t:dir relabelto;

audit2allow -R
require {
	type usr_t;
	type initrc_t;
	class dir relabelto;
}

#============= initrc_t ==============
allow initrc_t usr_t:dir relabelto;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-200.fc18.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-22 07:11:08 EDT

*** This bug has been marked as a duplicate of bug 976939 ***

Note You need to log in before you can comment on or make changes to this bug.