Bug 977065 - edit-node: Shown error info for "ovirt-node-plugin-cim " and null for "delta-manifest-rpm/srpm/file.txt".
edit-node: Shown error info for "ovirt-node-plugin-cim " and null for "delta-...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: haiyang,dong
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 03:08 EDT by haiyang,dong
Modified: 2014-03-31 08:32 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:32:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15990 None None None Never

  None (edit)
Description haiyang,dong 2013-06-23 03:08:13 EDT
Description of problem:
Install plugin "cim" into ovirt-node iso via executing follow command:
edit-node --repo=edit-node.repo --install=ovirt-node-plugin-cim-3.0.0-0.999.20130619041025git92b7aa2.fc18.noarch.rpm ovirt-node-iso-3.0.0-0.999.999.20130619041025git92b7aa2.2562.fc18.iso

check that shown error info for the file "/etc/ovirt-plugins.d/ovirt-node-plugin-cim"
[root@dhcp-10-214 admin]# cat /etc/ovirt-plugins.d/ovirt-node-plugin-cim 
Name:ovirt-node-plugin-cim
Version:ovirt-node-plugin-cim-package ovirt-node-plugin-cim-3.0.0-0.999.20130619041025git92b7aa2.fc18.noarch.rpm is not installed
Install Date:package ovirt-node-plugin-cim-3.0.0-0.999.20130619041025git92b7aa2.fc18.noarch.rpm is not installed

and shown null for these files "delta-manifest-rpm/srpm/file.txt"
[root@dhcp-10-214 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-rpm.txt 
[root@dhcp-10-214 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-srpm.txt 
[root@dhcp-10-214 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-file.txt 


Version-Release number of selected component (if applicable):
ovirt-node-tools-3.0.0-0.999.20130621153105gitd70da7c.fc18.noarch.rpm

How reproducible:
100%

QA Whiteboard: Security

Steps to Reproduce:



Actual results:


Expected results:


Additional info:
Comment 1 haiyang,dong 2013-06-23 03:41:01 EDT
http://gerrit.ovirt.org/#/c/15990/

edit-node: shown correct info for files ovirt-node-plugin-xxx
and delta-manifest-rpm/srpm/file.txt

After install cim plugin, check these files:
[root@dhcp-10-189 admin]# cat /etc/ovirt-plugins.d/ovirt-node-plugin-cim 
Name:ovirt-node-plugin-cim
Version:ovirt-node-plugin-cim-3.0.0-0.999.20130619041025git92b7aa2.fc18.noarch
Install Date:Sun Jun 23 06:01:54 2013

[root@dhcp-10-189 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-rpm.txt 
--- /current-manifest-rpm.txt	2013-06-23 06:02:02.700127586 +0000
+++ /manifest-rpm.txt	2013-06-23 06:01:58.887048670 +0000
+cim-schema-2.33.0-3.fc18.noarch (RSA/SHA256, Wed Nov 21 15:47:34 2012, Key ID ff01125cde7f38bd)
+gpg-pubkey-a4d647e9-501f7eef.(none) ((none))
+gpg-pubkey-ba094068-50d283ff.(none) ((none))
+gpg-pubkey-de7f38bd-501f4964.(none) ((none))
+gpg-pubkey-fb4b18e6-50b96bfd.(none) ((none))
+libcmpiutil-0.5.6-4.fc18.x86_64 (RSA/SHA256, Wed Nov  7 16:06:22 2012, Key ID ff01125cde7f38bd)
+libvirt-cim-0.6.1-3.fc18.x86_64 (RSA/SHA256, Fri Aug 10 23:06:44 2012, Key ID ff01125cde7f38bd)
+ovirt-node-plugin-cim-3.0.0-0.999.20130619041025git92b7aa2.fc18.noarch ((none))
......

[root@dhcp-10-189 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-srpm.txt 
--- /current-manifest-srpm.txt	2013-06-23 06:02:02.724128083 +0000
+++ /manifest-srpm.txt	2013-06-23 06:01:59.149054092 +0000
+cim-schema-2.33.0-3.fc18.src.rpm
.....

[root@dhcp-10-189 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-file.txt |more
--- /current-manifest-file.txt	2013-06-23 06:02:02.389121150 +0000
+++ /manifest-file.txt	2013-06-23 06:02:01.801108980 +0000
-0	/bin
-0	/dev/fd
-0	/dev/full
-0	/dev/null
-0	/dev/ptmx
-0	/dev/random
....
Comment 2 Sandro Bonazzola 2014-01-27 08:51:00 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 3 haiyang,dong 2014-03-03 01:18:58 EST
Test version:
ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso
ovirt-node-plugin-cim-3.0.4-1.0.el6.noarch.rpm
ovirt-node-tools-3.0.4-1.0.el6.noarch.rpm

edit-node: shown correct info for files ovirt-node-plugin-xxx
and delta-manifest-rpm/srpm/file.txt

After install cim plugin, check these files:
[root@dhcp-8-213 admin]# cat /etc/ovirt-plugins.d/ovirt-node-plugin-cim 
Name:ovirt-node-plugin-cim
Version:ovirt-node-plugin-cim-3.0.4-1.0.el6.noarch
Install Date:Sun Mar  2 21:10:07 2014


[root@dhcp-8-213 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-rpm.txt
--- /manifest-tmp-rpm.txt	2014-03-02 21:10:21.000000000 +0000
+++ /manifest-rpm.txt	2014-03-02 21:10:09.000000000 +0000
+cim-schema-2.22.0-2.1.el6.noarch (RSA/8, Sun Jul  3 04:02:16 2011, Key ID 0946f
ca2c105b9de)
+gpg-pubkey-c105b9de-4e0fd3a3.(none) ((none))
+gpg-pubkey-d0ff3d16-4e0fd442.(none) ((none))
+gpg-pubkey-ef1d6db8-4e0fd7f0.(none) ((none))
+gpg-pubkey-fe837f6f-4e0fd77e.(none) ((none))
+libcmpiutil-0.5.6-1.el6.x86_64 (RSA/SHA1, Thu Dec  8 20:16:08 2011, Key ID 0946
fca2c105b9de)
+libvirt-cim-0.6.1-9.el6_5.1.x86_64 (RSA/SHA1, Wed Feb 12 12:25:19 2014, Key ID 
0946fca2c105b9de)
+ovirt-node-plugin-cim-3.0.4-1.0.el6.noarch ((none))
......

[root@dhcp-8-213 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-srpm.txt
--- /manifest-tmp-srpm.txt	2014-03-02 21:10:21.000000000 +0000
+++ /manifest-srpm.txt	2014-03-02 21:10:09.000000000 +0000
+cim-schema-2.22.0-2.1.el6.src.rpm
.....

[root@dhcp-8-213 admin]# cat /etc/ovirt-plugins-manifests.d/delta-manifest-file.txt
--- /manifest-tmp-file.txt	2014-03-02 21:10:21.000000000 +0000
+++ /manifest-file.txt	2014-03-02 21:10:11.000000000 +0000
-0	/dev/pts
-0	/dev/shm
-0	/proc
-0	/sys
-100	/bin/sort
....

so this bug has been fixed, change the status into "verified".
Comment 4 Sandro Bonazzola 2014-03-31 08:32:51 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.