Bug 977163 - Unable to Push Via Git
Unable to Push Via Git
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 20:33 EDT by Anthony Brian Mallgren
Modified: 2013-08-14 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 19:11:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Brian Mallgren 2013-06-23 20:33:19 EDT
Description of problem: When I attempt to push via Git I receive the following error message:

ssh://51c6a1f1e0b8cd0782000065@i-vergency.rhcloud.com/~/git/i.git/: channel is not opened.


Version-Release number of selected component (if applicable):


How reproducible:

Open Eclipse with the OpenShift functionality installed, setup the project for the iVergency application, attempt to update, commit and push the code. The above error message should be displayed.

Steps to Reproduce:
1. Open Eclipse (with OpenShift functionality installed)
2. Setup the iVergency project.
3. Update, commit and push the code.

Actual results:

The following error message is displayed:

ssh://51c6a1f1e0b8cd0782000065@i-vergency.rhcloud.com/~/git/i.git/: channel is not opened.

Expected results:

The code should be pushed successfully.

Additional info:
Comment 1 Bill DeCoste 2013-06-24 14:02:11 EDT
What version of JDBS/JBossTools?
Comment 2 Bill DeCoste 2013-06-24 14:56:25 EDT
Also, does git from the command line work?
Comment 3 Bill DeCoste 2013-06-24 15:03:45 EDT
What versions of egit and jgit are installed in Eclipse?
Comment 4 Anthony Brian Mallgren 2013-06-25 05:13:57 EDT
I believe the tools on this laptop are version 1.4, for Juno.

The command line options on this laptop seem to be working.

I don't believe that any additional plugins in regards to get are installed in Eclipse on this laptop.

Everything seems to be working as expected now.
Comment 5 Bill DeCoste 2013-06-25 09:42:55 EDT
Is this JBossTools or JDBS? The "channel is not opened" error leads me to believe that there is a problem with the installed egit or jgit versions.
Comment 6 Jhon Honce 2013-08-14 19:11:38 EDT
Please reopen if this issue re-occurs.

Note You need to log in before you can comment on or make changes to this bug.