Bug 97719 - ifcfg for wireless written by neat has bad character in KEY field
ifcfg for wireless written by neat has bad character in KEY field
Status: CLOSED DUPLICATE of bug 88566
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 14:41 EDT by Bernhard Rupp
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rupp 2003-06-19 14:41:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Dell latitude C840
Linux 9.0 kernel-2.4.20-18.9
CISCO aironet 350 PCMCIA card
installed: kernel-pcmcia-cs-3.1.31-13
installed: wireless-tools-25-8
installed: redhat-config-network-1.2.0-2

card is recognized in lsmod:
[root@deepblue rpm]# /sbin/lsmod
Module			Size  Used by	 Tainted: P
airo_cs 		4900   0  (unused)
airo		       49608   1  [airo_cs]
ds			8680   2  [airo_cs]
yenta_socket	       13472   2
pcmcia_core	       57216   0  [airo_cs ds yenta_socket]
nls_iso8859-1		3516   0  (autoclean)

both on ifup and from neat/network
I get the same activating error:

[root@deepblue rpm]# /sbin/ifup eth1
Error for wireless request "Set Encode" (8B2A) :
    invalid argument "s:". <---- note the s:
 
Determining IP information for eth1... failed.

This appears to be caused by the KEY= entry in ifcfg-eth1:

[root@deepblue rpm]# tail  /etc/sysconfig/network-scripts/ifcfg-eth1
ONBOOT=yes
DHCP_HOSTNAME=
IPADDR=
NAME=
DOMAIN=
ESSID=
CHANNEL=1
MODE=Ad-Hoc
KEY=s:	       <--------------------bad s:
RATE=11Mb/s

I can fix this with editing the file and then restarting network:
[root@deepblue rpm]# tail  /etc/sysconfig/network-scripts/ifcfg-ethx
ONBOOT=yes
DHCP_HOSTNAME=
IPADDR=
NAME=
DOMAIN=
ESSID=
CHANNEL=1
MODE=Ad-Hoc
KEY=		<<------------ gone
RATE=11Mb/s

This removes the error message 

BUT:::

whenever I use the neat/network GUI and change 
a value, it recreates this darn KEY=s: and I need
to manually edit ifcfg-eth1 again.

Which script is causing this error? Can one fix it?

Thx, br 

Version-Release number of selected component (if applicable):
Linux 9.0 kernel-2.4.20-18.9
CISCO aironet 350 PCMCIA card
installed: kernel-pcmcia-cs-3.1.31-13
installed: wireless-tools-25-8
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. open neat
2. change wireless settings with no WEP key selected
3. commit changes
4. look at /etc/sysconfig/network-scripts/ifcfg-whatever_you_called_the_interface
    

Actual Results:  MODE=Ad-Hoc
KEY=s:	       <--------------------bad s:
RATE=11Mb/s


Expected Results:  MODE=Ad-Hoc
KEY=		<<------------ gone
RATE=11Mb/s


Additional info:
Comment 1 Harald Hoyer 2003-06-27 06:20:36 EDT
please try the update from
http://people.redhat.com/harald/redhat-config-network/
Comment 2 Harald Hoyer 2003-06-27 06:26:57 EDT

*** This bug has been marked as a duplicate of 88566 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.