Bug 97727 - build with non-existent user -> SHA1 failure when installing
build with non-existent user -> SHA1 failure when installing
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
: 91867 104650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 15:22 EDT by Enrico Scholz
Modified: 2007-04-18 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-26 20:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec-file (327 bytes, text/plain)
2003-06-19 15:25 EDT, Enrico Scholz
no flags Details

  None (edit)
Description Enrico Scholz 2003-06-19 15:22:50 EDT
Description of problem:

When having a package with a suid'ed binary which is owned by an
unknown user, rpm fails with a wrong and misleading message:

 ,---------------
| $ rpm -Uvh /usr/src/redhat/RPMS/i386/test2-0.1-1.i386.rpm
| Preparing...                ########################################### [100%]
| warning: user vcsaX does not exist - using root
|    1:test2                  ########################################### [100%]
| error: rpmdbAdd: skipping h#    5339 Header SHA1 digest: BAD Expected(5a3206989503b8b31bc89b05bfa1a220d9c48aee) != (84eabfc3b0c91606bccf9cf854259f07ee12f510)

This error confuses the rpm-db also:

| $ rpm -q test2
| $


Version-Release number of selected component (if applicable):

rpm-4.2-0.69
rpm-4.2.1-0.11


How reproducible:

100%
Comment 1 Enrico Scholz 2003-06-19 15:25:29 EDT
Created attachment 92497 [details]
spec-file

Steps to reproduce:

0. save as test2.spec
1. 'rpmbuild -bb test2.spec'
2. install resulting package
Comment 2 Jeff Johnson 2003-06-24 15:43:10 EDT
Ick.
Comment 3 Jeff Johnson 2003-06-25 10:53:25 EDT
*** Bug 91867 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Johnson 2003-09-19 08:31:17 EDT
*** Bug 104650 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2003-12-26 20:41:08 EST
Fixed in CVS, should be in rpm-4.2.2-0.8 and later.

Thanks for the reporducer.

$ sudo rpm -Uvh test2-0.1-1.i386.rpm
Preparing...               
########################################### [100%]
   1:test2                  warning: user vcsaX does not exist - using
root
########################################### [100%]
$ rpm -q test2
test2-0.1-1
Comment 6 John Flanagan 2004-05-12 00:27:21 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-098.html

Note You need to log in before you can comment on or make changes to this bug.