Bug 977281 - get_localhost_ip should raise exception
get_localhost_ip should raise exception
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: beta
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 04:28 EDT by Martin Magr
Modified: 2013-12-19 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.3.dev722.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:08:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 34196 None None None Never

  None (edit)
Description Martin Magr 2013-06-24 04:28:35 EDT
Description of problem:
Function get_localhost_ip should raise exception when it won't find IP address.

Actual results:
None is used as IP.

Expected results:
Some exception with correct message is raised.

Additional info:
openstack.rhttp://openstack.redhat.com/forum/discussion/113
Comment 3 Nir Magnezi 2013-11-13 03:28:56 EST
Martin, can you please provide some details about this exception?
How may I trigger it? (to verify this fix)
Comment 4 Martin Magr 2013-11-13 05:31:09 EST
Packstack is getting local IP by opening socket to your nameserver. So, you will have to turn off you network. You can also clean content in /etc/resolv.conf and block network communication to 8.8.8.8, which is default nameserver in case you don't have any ns set. Then packstack should fail with "Local IP address discovery failed. Please set nameserver correctly." message.
Comment 5 Nir Magnezi 2013-11-13 07:57:15 EST
(In reply to Martin Magr from comment #4)
> Packstack is getting local IP by opening socket to your nameserver. So, you
> will have to turn off you network. You can also clean content in
> /etc/resolv.conf and block network communication to 8.8.8.8, which is
> default nameserver in case you don't have any ns set. Then packstack should
> fail with "Local IP address discovery failed. Please set nameserver
> correctly." message.

Thanks you Martin.

Verified NVR: openstack-packstack-2013.2.1-0.9.dev840.el6ost.noarch

Verification Steps:
===================
1. install openstack-packstack
2. stop network service
3. run packstack

Result:
=======
packstack fails (as expected) with the following error:
Local IP address discovery faild. Please set nameserver correctly.
Comment 6 Scott Lewis 2013-12-16 13:56:45 EST
Auto qa_ack+ for VERIFIED bugs so they can be added to RC erratum
Comment 9 errata-xmlrpc 2013-12-19 19:08:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.