This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977354 - RHEVM-CLI: "power management user name" flag usage, wasn't updated as in help and auto complete
RHEVM-CLI: "power management user name" flag usage, wasn't updated as in help...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.1
Assigned To: Michael Pasternak
Ilia Meerovich
infra
: Regression, ZStream
Depends On: 969097 970237
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 07:27 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:02 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A power management property name was changed from 'power-management-username' to 'power-management-user_name' in the help and auto-complete output, however the command line shell did not accept the 'user_name' property. The property is now reverted to 'power-management-username' in the help output and can be used on the command line.
Story Points: ---
Clone Of: 970237
Environment:
Last Closed: 2013-07-16 11:30:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15299 None None None Never
oVirt gerrit 15304 None None None Never

  None (edit)
Comment 1 Michael Pasternak 2013-06-24 07:44:01 EDT
this bug regenerates the sdk according the #970237 change.
Comment 3 Ilia Meerovich 2013-06-25 08:15:00 EDT
[imeerovi@imeerovi ~]$ rpm -qa | grep rhevm-cli
rhevm-cli-3.2.1.1-1.el6ev.noarch

[RHEVM shell (connected)]# update host 
address                          correlation_id                   port                             power_management-enabled         power_management-pm_proxy        root_password                    
cluster-id                       display-address                  power_management-address         power_management-options-option  power_management-type            storage_manager-priority         
cluster-name                     name                             power_management-agents-agent    power_management-password        power_management-username        value                            
[RHEVM shell (connected)]# update 
cdrom          cluster        datacenter     disk           host           network        nic            role           storagedomain  tag            template       vm             vmpool         
[RHEVM shell (connected)]# update host 
address                          correlation_id                   port                             power_management-enabled         power_management-pm_proxy        root_password                    
cluster-id                       display-address                  power_management-address         power_management-options-option  power_management-type            storage_manager-priority         
cluster-name                     name                             power_management-agents-agent    power_management-password        power_management-username        value                            
[RHEVM shell (connected)]# update host 

error: wrong number of arguments, try 'help update' for help.

[RHEVM shell (connected)]# update host 
address                          correlation_id                   port                             power_management-enabled         power_management-pm_proxy        root_password                    
cluster-id                       display-address                  power_management-address         power_management-options-option  power_management-type            storage_manager-priority         
cluster-name                     name                             power_management-agents-agent    power_management-password        power_management-username        value                            
[RHEVM shell (connected)]# update host po
port                             power_management-agents-agent    power_management-options-option  power_management-pm_proxy        power_management-username        
power_management-address         power_management-enabled         power_management-password        power_management-type            
[RHEVM shell (connected)]# update host power_management-
power_management-address         power_management-enabled         power_management-password        power_management-type            
power_management-agents-agent    power_management-options-option  power_management-pm_proxy        power_management-username        
[RHEVM shell (connected)]# update host --power_management-username 
[imeerovi@imeerovi ~]$ /usr/bin/rhevm-shell -c --url=https://ilia-rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal -I


 ==========================================
 >>> connected to RHEVM manager 3.2.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# help add host

USAGE
  
  add <type> [parent identifiers] [command options]
  
DESCRIPTION
  
  Creates a new object or adds existent with type host. See 'help add' for generic
  help on creating objects.
  
ATTRIBUTE OPTIONS
  
  The following options are available for objects with type host:
  
    * --name: string
    * --address: string
    * --root_password: string
    * --cluster-id|name: string
    * [--port: int]
    * [--display-address: string]
    * [--storage_manager-priority: int]
    * [--power_management-type: string]
    * [--power_management-enabled: boolean]
    * [--power_management-address: string]
    * [--power_management-username: string]
    * [--power_management-password: string]
    * [--power_management-options-option: collection]
      {
        [option.name: string]
        [option.value: string]
      }
    * [--power_management-pm_proxy: collection]
      {
        [propietary: string]
      }
    * [--power_management-agents-agent: collection]
      {
        [type: string]
        [address: string]
        [user_name: string]
        [password: string]
        [options.option: collection]
      {
    * [--name: string]
    * [--value: string]
      }
      }
    * [--reboot_after_installation: boolean]
    * [--expect: 201-created]
    * [--correlation_id: anystring]
  
COLLECTION BASED OPTION FORMAT
  
    * [--x-y: collection]
[RHEVM shell (connected)]#
Comment 5 errata-xmlrpc 2013-07-16 11:30:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1078.html

Note You need to log in before you can comment on or make changes to this bug.