Bug 977374 - qpid-tools help typos (CRAM-MD -> CRAM-MD5)
qpid-tools help typos (CRAM-MD -> CRAM-MD5)
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools (Show other bugs)
2.3
Unspecified Unspecified
low Severity low
: 3.0
: ---
Assigned To: Ernie
Frantisek Reznicek
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 07:56 EDT by Frantisek Reznicek
Modified: 2015-11-15 20:14 EST (History)
7 users (show)

See Also:
Fixed In Version: qpid-tools-0.22-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-24 11:08:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change comments and usage text CRAM-MD -> CRAM-MD5 (23.16 KB, patch)
2013-09-11 13:02 EDT, Ernie
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5169 None None None Never

  None (edit)
Description Frantisek Reznicek 2013-06-24 07:56:19 EDT
Description of problem:
qpid-tools help are comming with CRAM-MD5 typos:

[root@dhcp-x116 bz]# qpid-config -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). SASL
[root@dhcp-x116 bz]# qpid-config -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). SASL
[root@dhcp-x116 bz]# qpid-stat -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). SASL
[root@dhcp-x116 bz]# qpid-route -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). Used
[root@dhcp-x116 bz]# qpid-tool -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). SASL
[root@dhcp-x116 bz]# qpid-cluster -h | grep CRAM
                        ANONYMOUS, PLAIN, CRAM-MD, DIGEST-MD5, GSSAPI). SASL

Correction CRAM-MD -> CRAM-MD5 should be made.


Version-Release number of selected component (if applicable):
qpid-tools-0.22-2.el5

How reproducible:
100%

Steps to Reproduce:
1. qpid-config -h | grep CRAM ...

Actual results:
CRAM-MD

Expected results:
CRAM-MD5

Additional info:
Comment 2 Ernie 2013-09-11 13:02:43 EDT
Created attachment 796453 [details]
Change comments and usage text CRAM-MD -> CRAM-MD5

Also effects some of the java tools
Comment 3 Ernie 2013-09-11 13:07:07 EDT
Changed the following tools:
cpp/src/tests/ping_broker
tools/src/py/qpid-cluster
tools/src/py/qpid-tool
tools/src/py/qpid-route
tools/src/py/qpid-queue-stats
tools/src/py/qpid-ha
tools/src/py/qpid-stat
tools/src/py/qpid-printevents
tools/src/py/qpid-config
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/QpidConfig.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/QueueFuse.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/QpidPrintEvents.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/ConnectionLogger.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/QpidCtrl.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/QpidQueueStats.java
tools/src/java/src/main/java/org/apache/qpid/qmf2/tools/ConnectionAudit.java
Comment 5 Justin Ross 2013-09-26 14:20:22 EDT
https://svn.apache.org/r1526637
Comment 9 Frantisek Reznicek 2013-11-29 02:54:36 EST
The issue has been fixed, tested on RHEL6.4/5 i/x with packages:

perl-qpid-0.22-7.el6.x86_64
perl-qpid-debuginfo-0.22-7.el6.x86_64
python-qpid-0.22-8.el6.noarch
python-qpid-proton-0.5-9.el6.x86_64
python-qpid-proton-doc-0.5-9.el6.noarch
python-qpid-qmf-0.22-24.el6.x86_64
qpid-cpp-client-0.22-29.el6.x86_64
qpid-cpp-client-devel-0.22-29.el6.x86_64
qpid-cpp-client-devel-docs-0.22-29.el6.noarch
qpid-cpp-client-rdma-0.22-29.el6.x86_64
qpid-cpp-client-ssl-0.22-29.el6.x86_64
qpid-cpp-debuginfo-0.22-29.el6.x86_64
qpid-cpp-server-0.22-29.el6.x86_64
qpid-cpp-server-devel-0.22-29.el6.x86_64
qpid-cpp-server-ha-0.22-29.el6.x86_64
qpid-cpp-server-linearstore-0.22-29.el6.x86_64
qpid-cpp-server-rdma-0.22-29.el6.x86_64
qpid-cpp-server-ssl-0.22-29.el6.x86_64
qpid-cpp-server-store-0.22-29.el6.x86_64
qpid-cpp-server-xml-0.22-29.el6.x86_64
qpid-java-amqp-0-10-client-jms-0.23-4.el6.noarch
qpid-java-client-0.23-4.el6.noarch
qpid-java-common-0.23-4.el6.noarch
qpid-java-example-0.23-4.el6.noarch
qpid-jca-0.22-1.el6.noarch
qpid-jca-xarecovery-0.22-1.el6.noarch
qpid-jca-zip-0.22-1.el6.noarch
qpid-proton-c-0.5-9.el6.x86_64
qpid-proton-c-devel-0.5-9.el6.x86_64
qpid-proton-c-devel-doc-0.5-9.el6.noarch
qpid-proton-debuginfo-0.5-9.el6.x86_64
qpid-qmf-0.22-24.el6.x86_64
qpid-qmf-debuginfo-0.22-24.el6.x86_64
qpid-qmf-devel-0.22-24.el6.x86_64
qpid-snmpd-1.0.0-14.el6.x86_64
qpid-snmpd-debuginfo-1.0.0-14.el6.x86_64
qpid-tests-0.22-11.el6.noarch
qpid-tools-0.22-7.el6.noarch
rh-qpid-cpp-tests-0.22-29.el6.x86_64
ruby-qpid-qmf-0.22-24.el6.x86_64



# for i_tool in $(rpm -ql qpid-tools|grep bin/); do echo ${i_tool};${i_tool} -h|grep CRAM;done
/usr/bin/qmf-tool
/usr/bin/qpid-config
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). SASL
/usr/bin/qpid-printevents
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). SASL
/usr/bin/qpid-queue-stats
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). SASL
/usr/bin/qpid-route
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). Used
/usr/bin/qpid-stat
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). SASL
/usr/bin/qpid-tool
                        ANONYMOUS, PLAIN, CRAM-MD5, DIGEST-MD5, GSSAPI). SASL

-> VERIFIED
Comment 10 errata-xmlrpc 2014-09-24 11:08:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.